diff options
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/keepalived/keepalived/0001-vrrp-Don-t-include-linux-if_ether.h-if-not-needed.patch b/meta-networking/recipes-daemons/keepalived/keepalived/0001-vrrp-Don-t-include-linux-if_ether.h-if-not-needed.patch new file mode 100644 index 0000000000..f6a38668ee --- /dev/null +++ b/meta-networking/recipes-daemons/keepalived/keepalived/0001-vrrp-Don-t-include-linux-if_ether.h-if-not-needed.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From f129c588f7c8a66e595d8ae96a43d585018e79cd Mon Sep 17 00:00:00 2001 | ||
2 | From: Quentin Armitage <quentin@armitage.org.uk> | ||
3 | Date: Thu, 7 Nov 2024 11:09:43 +0000 | ||
4 | Subject: [PATCH] vrrp: Don't include <linux/if_ether.h> if not needed | ||
5 | |||
6 | The musl headers do not allow including both <linux/if_ether.h> and | ||
7 | <net/ethernet.h> since they both define struct ethhdr. | ||
8 | |||
9 | It is likely that we do not need to include <linux/if_ether.h> at all | ||
10 | since with both glibc and musl including <net/ethernet.h> is sufficient, | ||
11 | but removing <linux/if_ether.h> is for another day. | ||
12 | |||
13 | Upstream-Status: Backport [https://github.com/acassen/keepalived/commit/f129c588f7c8a66e595d8ae96a43d585018e79cd] | ||
14 | Signed-off-by: Quentin Armitage <quentin@armitage.org.uk> | ||
15 | --- | ||
16 | keepalived/vrrp/vrrp.c | 4 +++- | ||
17 | 1 file changed, 3 insertions(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/keepalived/vrrp/vrrp.c b/keepalived/vrrp/vrrp.c | ||
20 | index 96b2c4c8..4b06e387 100644 | ||
21 | --- a/keepalived/vrrp/vrrp.c | ||
22 | +++ b/keepalived/vrrp/vrrp.c | ||
23 | @@ -40,8 +40,10 @@ | ||
24 | #include <netinet/ip6.h> | ||
25 | #include <stdint.h> | ||
26 | #include <net/if_arp.h> | ||
27 | -#include <linux/if_ether.h> | ||
28 | #include <net/ethernet.h> | ||
29 | +#if !defined ETH_HLEN || !defined ETH_ZLEN | ||
30 | +#include <linux/if_ether.h> /* This may not be needed at all - try removing and see if any issues raised */ | ||
31 | +#endif | ||
32 | #ifdef _NETWORK_TIMESTAMP_ | ||
33 | #include <linux/net_tstamp.h> | ||
34 | #endif | ||
diff --git a/meta-networking/recipes-daemons/keepalived/keepalived_2.3.2.bb b/meta-networking/recipes-daemons/keepalived/keepalived_2.3.2.bb index 2cb76e6d41..c0a2e57bfb 100644 --- a/meta-networking/recipes-daemons/keepalived/keepalived_2.3.2.bb +++ b/meta-networking/recipes-daemons/keepalived/keepalived_2.3.2.bb | |||
@@ -12,6 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | |||
12 | 12 | ||
13 | SRC_URI = "http://www.keepalived.org/software/${BP}.tar.gz \ | 13 | SRC_URI = "http://www.keepalived.org/software/${BP}.tar.gz \ |
14 | file://0001-configure.ac-Do-not-emit-compiler-flags-into-object-.patch \ | 14 | file://0001-configure.ac-Do-not-emit-compiler-flags-into-object-.patch \ |
15 | file://0001-vrrp-Don-t-include-linux-if_ether.h-if-not-needed.patch \ | ||
15 | " | 16 | " |
16 | SRC_URI[sha256sum] = "77f4a22e5a23fa8e49b8916acdfb584c864e72905a2f1de2a7f62ed40a896160" | 17 | SRC_URI[sha256sum] = "77f4a22e5a23fa8e49b8916acdfb584c864e72905a2f1de2a7f62ed40a896160" |
17 | UPSTREAM_CHECK_URI = "https://github.com/acassen/keepalived/releases" | 18 | UPSTREAM_CHECK_URI = "https://github.com/acassen/keepalived/releases" |