diff options
-rw-r--r-- | meta-oe/recipes-support/gsoap/gsoap/0001-stdgsoap2-Fix-build-with-musl.patch | 63 | ||||
-rw-r--r-- | meta-oe/recipes-support/gsoap/gsoap_2.8.51.bb | 3 |
2 files changed, 65 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/gsoap/gsoap/0001-stdgsoap2-Fix-build-with-musl.patch b/meta-oe/recipes-support/gsoap/gsoap/0001-stdgsoap2-Fix-build-with-musl.patch new file mode 100644 index 0000000000..571cbe5409 --- /dev/null +++ b/meta-oe/recipes-support/gsoap/gsoap/0001-stdgsoap2-Fix-build-with-musl.patch | |||
@@ -0,0 +1,63 @@ | |||
1 | From db260fbc7af4c73c997c485a0c69c61594a0e59c Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 30 Aug 2017 19:48:50 -0700 | ||
4 | Subject: [PATCH] stdgsoap2: Fix build with musl | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | gsoap/stdsoap2.c | 2 +- | ||
9 | gsoap/stdsoap2.cpp | 4 ++-- | ||
10 | gsoap/stdsoap2.h | 2 +- | ||
11 | 3 files changed, 4 insertions(+), 4 deletions(-) | ||
12 | |||
13 | diff --git a/gsoap/stdsoap2.c b/gsoap/stdsoap2.c | ||
14 | index 58e9df4..62389e1 100644 | ||
15 | --- a/gsoap/stdsoap2.c | ||
16 | +++ b/gsoap/stdsoap2.c | ||
17 | @@ -4462,7 +4462,7 @@ tcp_gethost(struct soap *soap, const char *addr, struct in_addr *inaddr) | ||
18 | return soap->error = SOAP_EOM; | ||
19 | return SOAP_OK; | ||
20 | } | ||
21 | -#if defined(__GLIBC__) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__) | ||
22 | +#if defined(LINUX) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__) | ||
23 | if (gethostbyname_r(addr, &hostent, soap->buf, sizeof(soap->buf), &host, &soap->errnum) < 0) | ||
24 | host = NULL; | ||
25 | #elif defined(_AIX43) || ((defined(TRU64) || defined(HP_UX)) && defined(HAVE_GETHOSTBYNAME_R)) | ||
26 | diff --git a/gsoap/stdsoap2.cpp b/gsoap/stdsoap2.cpp | ||
27 | index 58e9df4..b637161 100644 | ||
28 | --- a/gsoap/stdsoap2.cpp | ||
29 | +++ b/gsoap/stdsoap2.cpp | ||
30 | @@ -4462,7 +4462,7 @@ tcp_gethost(struct soap *soap, const char *addr, struct in_addr *inaddr) | ||
31 | return soap->error = SOAP_EOM; | ||
32 | return SOAP_OK; | ||
33 | } | ||
34 | -#if defined(__GLIBC__) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__) | ||
35 | +#if defined(LINUX) || (defined(HAVE_GETHOSTBYNAME_R) && (defined(FREEBSD) || defined(__FreeBSD__))) || defined(__ANDROID__) | ||
36 | if (gethostbyname_r(addr, &hostent, soap->buf, sizeof(soap->buf), &host, &soap->errnum) < 0) | ||
37 | host = NULL; | ||
38 | #elif defined(_AIX43) || ((defined(TRU64) || defined(HP_UX)) && defined(HAVE_GETHOSTBYNAME_R)) | ||
39 | @@ -19658,7 +19658,7 @@ soap_strerror(struct soap *soap) | ||
40 | { | ||
41 | #ifndef WIN32 | ||
42 | # ifdef HAVE_STRERROR_R | ||
43 | -# if defined(_GNU_SOURCE) && !defined(__ANDROID__) | ||
44 | +# if defined(_GNU_SOURCE) && !defined(__ANDROID__) && defined(__GLIBC__) | ||
45 | return strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* GNU-specific */ | ||
46 | # else | ||
47 | strerror_r(err, soap->msgbuf, sizeof(soap->msgbuf)); /* XSI-compliant */ | ||
48 | diff --git a/gsoap/stdsoap2.h b/gsoap/stdsoap2.h | ||
49 | index 07a3952..c6ace4c 100644 | ||
50 | --- a/gsoap/stdsoap2.h | ||
51 | +++ b/gsoap/stdsoap2.h | ||
52 | @@ -947,7 +947,7 @@ extern "C" { | ||
53 | # endif | ||
54 | #elif defined(SOCKLEN_T) | ||
55 | # define SOAP_SOCKLEN_T SOCKLEN_T | ||
56 | -#elif defined(__socklen_t_defined) || defined(_SOCKLEN_T) || defined(CYGWIN) || defined(FREEBSD) || defined(__FreeBSD__) || defined(OPENBSD) || defined(__QNX__) || defined(QNX) || defined(OS390) || defined(__ANDROID__) || defined(_XOPEN_SOURCE) | ||
57 | +#elif defined(__socklen_t_defined) || defined(_SOCKLEN_T) || defined(CYGWIN) || defined(FREEBSD) || defined(__FreeBSD__) || defined(OPENBSD) || defined(__QNX__) || defined(QNX) || defined(OS390) || defined(__ANDROID__) || defined(_XOPEN_SOURCE) || defined (LINUX) | ||
58 | # define SOAP_SOCKLEN_T socklen_t | ||
59 | #elif defined(IRIX) || defined(WIN32) || defined(__APPLE__) || defined(SUN_OS) || defined(OPENSERVER) || defined(TRU64) || defined(VXWORKS) | ||
60 | # define SOAP_SOCKLEN_T int | ||
61 | -- | ||
62 | 2.14.1 | ||
63 | |||
diff --git a/meta-oe/recipes-support/gsoap/gsoap_2.8.51.bb b/meta-oe/recipes-support/gsoap/gsoap_2.8.51.bb index 41fccb533f..8875844615 100644 --- a/meta-oe/recipes-support/gsoap/gsoap_2.8.51.bb +++ b/meta-oe/recipes-support/gsoap/gsoap_2.8.51.bb | |||
@@ -7,7 +7,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4f40a941379143186f9602242c3fb729 \ | |||
7 | 7 | ||
8 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}2/${BPN}_${PV}.zip \ | 8 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}2/${BPN}_${PV}.zip \ |
9 | file://0001-Fix-out-of-tree-builds.patch \ | 9 | file://0001-Fix-out-of-tree-builds.patch \ |
10 | " | 10 | file://0001-stdgsoap2-Fix-build-with-musl.patch \ |
11 | " | ||
11 | SRC_URI[md5sum] = "212951d6e1435bb51fa4320f458809ea" | 12 | SRC_URI[md5sum] = "212951d6e1435bb51fa4320f458809ea" |
12 | SRC_URI[sha256sum] = "3e7bb24a9e492f5cb86daca34054c9787152f1d7b70add36b789d03816d5ffa1" | 13 | SRC_URI[sha256sum] = "3e7bb24a9e492f5cb86daca34054c9787152f1d7b70add36b789d03816d5ffa1" |
13 | 14 | ||