diff options
-rw-r--r-- | meta-oe/recipes-devtools/php/php/0001-opcache-config.m4-enable-opcache.patch | 81 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php/0049-ext-intl-Use-pkg-config-to-detect-icu.patch | 154 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/php/php_7.3.4.bb (renamed from meta-oe/recipes-devtools/php/php_7.3.2.bb) | 4 |
3 files changed, 118 insertions, 121 deletions
diff --git a/meta-oe/recipes-devtools/php/php/0001-opcache-config.m4-enable-opcache.patch b/meta-oe/recipes-devtools/php/php/0001-opcache-config.m4-enable-opcache.patch index 9ffd0e4de1..34f433f40a 100644 --- a/meta-oe/recipes-devtools/php/php/0001-opcache-config.m4-enable-opcache.patch +++ b/meta-oe/recipes-devtools/php/php/0001-opcache-config.m4-enable-opcache.patch | |||
@@ -1,7 +1,9 @@ | |||
1 | From fb139d9707dabe1684b472a08a6eb5761ede4a3a Mon Sep 17 00:00:00 2001 | 1 | From 8de5ba69d20d049b8ca983a9470c7303142ec0b3 Mon Sep 17 00:00:00 2001 |
2 | From: Changqing Li <changqing.li@windriver.com> | 2 | From: Changqing Li <changqing.li@windriver.com> |
3 | Date: Tue, 12 Feb 2019 14:56:16 +0800 | 3 | Date: Sun, 28 Apr 2019 16:55:13 +0800 |
4 | Subject: [PATCH] opcache/config.m4: enable opcache | 4 | Subject: [PATCH] From fb139d9707dabe1684b472a08a6eb5761ede4a3a Mon Sep 17 |
5 | 00:00:00 2001 From: Changqing Li <changqing.li@windriver.com> Date: Tue, 12 | ||
6 | Feb 2019 14:56:16 +0800 Subject: [PATCH] opcache/config.m4: enable opcache | ||
5 | 7 | ||
6 | We can't use AC_TRY_RUN to run programs in a cross compile environment. Set | 8 | We can't use AC_TRY_RUN to run programs in a cross compile environment. Set |
7 | the variables directly instead since we know that we'd be running on latest | 9 | the variables directly instead since we know that we'd be running on latest |
@@ -11,17 +13,17 @@ Upstream-Status: Inappropriate [Configuration] | |||
11 | 13 | ||
12 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> | 14 | Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> |
13 | 15 | ||
14 | update patch to version 7.3.2 | 16 | update patch to version 7.3.4 |
15 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | 17 | Signed-off-by: Changqing Li <changqing.li@windriver.com> |
16 | --- | 18 | --- |
17 | ext/opcache/config.m4 | 357 +------------------------------------------------- | 19 | ext/opcache/config.m4 | 312 +------------------------------------------------- |
18 | 1 file changed, 6 insertions(+), 351 deletions(-) | 20 | 1 file changed, 6 insertions(+), 306 deletions(-) |
19 | 21 | ||
20 | diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4 | 22 | diff --git a/ext/opcache/config.m4 b/ext/opcache/config.m4 |
21 | index 392f4c6..6617693 100644 | 23 | index 4810217..22c3d61 100644 |
22 | --- a/ext/opcache/config.m4 | 24 | --- a/ext/opcache/config.m4 |
23 | +++ b/ext/opcache/config.m4 | 25 | +++ b/ext/opcache/config.m4 |
24 | @@ -27,374 +27,29 @@ if test "$PHP_OPCACHE" != "no"; then | 26 | @@ -27,319 +27,19 @@ if test "$PHP_OPCACHE" != "no"; then |
25 | AC_CHECK_HEADERS([unistd.h sys/uio.h]) | 27 | AC_CHECK_HEADERS([unistd.h sys/uio.h]) |
26 | 28 | ||
27 | AC_MSG_CHECKING(for sysvipc shared memory support) | 29 | AC_MSG_CHECKING(for sysvipc shared memory support) |
@@ -93,8 +95,9 @@ index 392f4c6..6617693 100644 | |||
93 | - AC_DEFINE(HAVE_SHM_IPC, 1, [Define if you have SysV IPC SHM support]) | 95 | - AC_DEFINE(HAVE_SHM_IPC, 1, [Define if you have SysV IPC SHM support]) |
94 | - msg=yes],[msg=no],[msg=no]) | 96 | - msg=yes],[msg=no],[msg=no]) |
95 | - AC_MSG_RESULT([$msg]) | 97 | - AC_MSG_RESULT([$msg]) |
98 | - | ||
96 | + AC_DEFINE(HAVE_SHM_IPC, 1, [Define if you have SysV IPC SHM support]) | 99 | + AC_DEFINE(HAVE_SHM_IPC, 1, [Define if you have SysV IPC SHM support]) |
97 | 100 | + | |
98 | AC_MSG_CHECKING(for mmap() using MAP_ANON shared memory support) | 101 | AC_MSG_CHECKING(for mmap() using MAP_ANON shared memory support) |
99 | - AC_RUN_IFELSE([AC_LANG_SOURCE([[ | 102 | - AC_RUN_IFELSE([AC_LANG_SOURCE([[ |
100 | -#include <sys/types.h> | 103 | -#include <sys/types.h> |
@@ -344,64 +347,8 @@ index 392f4c6..6617693 100644 | |||
344 | - AC_MSG_RESULT([$msg]) | 347 | - AC_MSG_RESULT([$msg]) |
345 | + AC_DEFINE(HAVE_SHM_MMAP_FILE, 1, [Define if you have mmap() SHM support]) | 348 | + AC_DEFINE(HAVE_SHM_MMAP_FILE, 1, [Define if you have mmap() SHM support]) |
346 | 349 | ||
347 | flock_type=unknown | 350 | PHP_NEW_EXTENSION(opcache, |
348 | AC_MSG_CHECKING(for struct flock layout) | 351 | ZendAccelerator.c \ |
349 | |||
350 | if test "$flock_type" = "unknown"; then | ||
351 | -AC_RUN_IFELSE([AC_LANG_SOURCE([[ | ||
352 | - #include <fcntl.h> | ||
353 | - struct flock lock = { 1, 2, 3, 4, 5, 6, 7 }; | ||
354 | - int main() { | ||
355 | - if(lock.l_type == 1 && lock.l_whence == 2 && lock.l_start == 6 && lock.l_len== 7) { | ||
356 | - return 0; | ||
357 | - } | ||
358 | - return 1; | ||
359 | - } | ||
360 | -]])], [ | ||
361 | - flock_type=aix64 | ||
362 | - AC_DEFINE([HAVE_FLOCK_AIX64], [], [Struct flock is 64-bit AIX-type]) | ||
363 | -], []) | ||
364 | -fi | ||
365 | - | ||
366 | -if test "$flock_type" = "unknown"; then | ||
367 | -AC_RUN_IFELSE([AC_LANG_SOURCE([[ | ||
368 | - #include <fcntl.h> | ||
369 | - struct flock lock = { 1, 2, 3, 4, 5 }; | ||
370 | - int main() { | ||
371 | - if(lock.l_type == 1 && lock.l_whence == 2 && lock.l_start == 3 && lock.l_len == 4) { | ||
372 | - return 0; | ||
373 | - } | ||
374 | - return 1; | ||
375 | - } | ||
376 | -]])], [ | ||
377 | - flock_type=linux | ||
378 | + flock_type=linux | ||
379 | AC_DEFINE([HAVE_FLOCK_LINUX], [], [Struct flock is Linux-type]) | ||
380 | -], []) | ||
381 | fi | ||
382 | |||
383 | if test "$flock_type" = "unknown"; then | ||
384 | -AC_RUN_IFELSE([AC_LANG_SOURCE([[ | ||
385 | - #include <fcntl.h> | ||
386 | - struct flock lock = { 1, 2, 3, 4, 5 }; | ||
387 | - int main() { | ||
388 | - if(lock.l_start == 1 && lock.l_len == 2 && lock.l_type == 4 && lock.l_whence == 5) { | ||
389 | - return 0; | ||
390 | - } | ||
391 | - return 1; | ||
392 | - } | ||
393 | -]])], [ | ||
394 | - flock_type=bsd | ||
395 | - AC_DEFINE([HAVE_FLOCK_BSD], [], [Struct flock is BSD-type]) | ||
396 | -], []) | ||
397 | -fi | ||
398 | - | ||
399 | -AC_MSG_RESULT([$flock_type]) | ||
400 | - | ||
401 | -if test "$flock_type" = "unknown"; then | ||
402 | AC_MSG_ERROR([Don't know how to define struct flock on this system[,] set --enable-opcache=no]) | ||
403 | fi | ||
404 | |||
405 | -- | 352 | -- |
406 | 2.7.4 | 353 | 2.7.4 |
407 | 354 | ||
diff --git a/meta-oe/recipes-devtools/php/php/0049-ext-intl-Use-pkg-config-to-detect-icu.patch b/meta-oe/recipes-devtools/php/php/0049-ext-intl-Use-pkg-config-to-detect-icu.patch index deada1ff97..2258c4c7fa 100644 --- a/meta-oe/recipes-devtools/php/php/0049-ext-intl-Use-pkg-config-to-detect-icu.patch +++ b/meta-oe/recipes-devtools/php/php/0049-ext-intl-Use-pkg-config-to-detect-icu.patch | |||
@@ -1,84 +1,131 @@ | |||
1 | From: Hugh McMaster <hugh.mcmaster@outlook.com> | 1 | From 03fecab78f9fa747ad8ab3484e7ca00c0148321d Mon Sep 17 00:00:00 2001 |
2 | Date: Wed, 5 Dec 2018 23:27:30 +1100 | 2 | From: Changqing Li <changqing.li@windriver.com> |
3 | Subject: ext/intl: Use pkg-config to detect icu | 3 | Date: Sun, 28 Apr 2019 16:45:02 +0800 |
4 | Subject: [PATCH] From: Hugh McMaster <hugh.mcmaster@outlook.com> Date: Wed, 5 | ||
5 | Dec 2018 23:27:30 +1100 Subject: ext/intl: Use pkg-config to detect icu | ||
4 | 6 | ||
5 | The developers of icu recommend using pkg-config to detect icu, | 7 | The developers of icu recommend using pkg-config to detect icu, |
6 | because icu-config is deprecated. | 8 | because icu-config is deprecated. |
9 | |||
10 | Upstream-Status: Pending | ||
11 | |||
12 | update to version 7.3.4 | ||
13 | Signed-off-by: Changqing Li <changqing.li@windriver.com> | ||
7 | --- | 14 | --- |
8 | acinclude.m4 | 56 +++++++----------------------------------------------- | 15 | acinclude.m4 | 95 ++++++------------------------------------------------ |
9 | ext/intl/config.m4 | 16 ++++++---------- | 16 | ext/intl/config.m4 | 16 ++++----- |
10 | 2 files changed, 13 insertions(+), 59 deletions(-) | 17 | 2 files changed, 15 insertions(+), 96 deletions(-) |
11 | 18 | ||
12 | --- php7.3.orig/acinclude.m4 | 19 | diff --git a/acinclude.m4 b/acinclude.m4 |
13 | +++ php7.3/acinclude.m4 | 20 | index 7d77c33..86b0ecc 100644 |
14 | @@ -2168,58 +2168,16 @@ dnl | 21 | --- a/acinclude.m4 |
22 | +++ b/acinclude.m4 | ||
23 | @@ -2158,92 +2158,15 @@ dnl | ||
15 | dnl Common setup macro for ICU | 24 | dnl Common setup macro for ICU |
16 | dnl | 25 | dnl |
17 | AC_DEFUN([PHP_SETUP_ICU],[ | 26 | AC_DEFUN([PHP_SETUP_ICU],[ |
18 | - PHP_ARG_WITH(icu-dir,, | 27 | - PHP_ARG_WITH(icu-dir,, |
19 | - [ --with-icu-dir=DIR Specify where ICU libraries and headers can be found], DEFAULT, no) | 28 | - [ --with-icu-dir=DIR Specify where ICU libraries and headers can be found], DEFAULT, no) |
20 | + PKG_CHECK_MODULES([ICU], [icu-io >= 50.1]) | 29 | - |
21 | |||
22 | - if test "$PHP_ICU_DIR" = "no"; then | 30 | - if test "$PHP_ICU_DIR" = "no"; then |
23 | - PHP_ICU_DIR=DEFAULT | 31 | - PHP_ICU_DIR=DEFAULT |
24 | - fi | 32 | - fi |
25 | - | 33 | - |
26 | - if test "$PHP_ICU_DIR" = "DEFAULT"; then | 34 | - AC_MSG_CHECKING([for location of ICU headers and libraries]) |
27 | - dnl Try to find icu-config | 35 | - found_icu=no |
28 | - AC_PATH_PROG(ICU_CONFIG, icu-config, no, [$PATH:/usr/local/bin]) | 36 | - |
29 | - else | 37 | - dnl First try to find pkg-config |
30 | - ICU_CONFIG="$PHP_ICU_DIR/bin/icu-config" | 38 | - if test -z "$PKG_CONFIG"; then |
39 | - AC_PATH_PROG(PKG_CONFIG, pkg-config, no) | ||
31 | - fi | 40 | - fi |
32 | - | 41 | - |
33 | - AC_MSG_CHECKING([for location of ICU headers and libraries]) | 42 | - dnl If pkg-config is found try using it |
43 | - if test "$PHP_ICU_DIR" = "DEFAULT" && test -x "$PKG_CONFIG" && $PKG_CONFIG --exists icu-uc icu-io icu-i18n; then | ||
44 | - if $PKG_CONFIG --atleast-version=40 icu-uc; then | ||
45 | - found_icu=yes | ||
46 | - icu_version_full=`$PKG_CONFIG --modversion icu-uc` | ||
47 | - ac_IFS=$IFS | ||
48 | - IFS="." | ||
49 | - set $icu_version_full | ||
50 | - IFS=$ac_IFS | ||
51 | - icu_version=`expr [$]1 \* 1000 + [$]2` | ||
52 | - AC_MSG_RESULT([found $icu_version_full]) | ||
34 | - | 53 | - |
35 | - dnl Trust icu-config to know better what the install prefix is.. | 54 | - ICU_LIBS=`$PKG_CONFIG --libs icu-uc icu-io icu-i18n` |
36 | - icu_install_prefix=`$ICU_CONFIG --prefix 2> /dev/null` | 55 | - ICU_INCS=`$PKG_CONFIG --cflags-only-I icu-uc icu-io icu-i18n` |
37 | - if test "$?" != "0" || test -z "$icu_install_prefix"; then | 56 | - ICU_CXXFLAGS="-DU_USING_ICU_NAMESPACE=1" |
38 | - AC_MSG_RESULT([not found]) | ||
39 | - AC_MSG_ERROR([Unable to detect ICU prefix or $ICU_CONFIG failed. Please verify ICU install prefix and make sure icu-config works.]) | ||
40 | - else | ||
41 | - AC_MSG_RESULT([$icu_install_prefix]) | ||
42 | - | 57 | - |
43 | - dnl Check ICU version | 58 | - AC_MSG_RESULT([found $ICU_VERSION]) |
44 | - AC_MSG_CHECKING([for ICU 4.0 or greater]) | 59 | - |
45 | - icu_version_full=`$ICU_CONFIG --version` | 60 | - PHP_EVAL_LIBLINE($ICU_LIBS, $1) |
46 | - ac_IFS=$IFS | 61 | - PHP_EVAL_INCLINE($ICU_INCS) |
47 | - IFS="." | 62 | - else |
48 | - set $icu_version_full | 63 | - AC_MSG_ERROR([ICU version 4.0 or later required.]) |
49 | - IFS=$ac_IFS | 64 | - fi |
50 | - icu_version=`expr [$]1 \* 1000 + [$]2` | 65 | - fi |
51 | - AC_MSG_RESULT([found $icu_version_full]) | ||
52 | - | 66 | - |
53 | - if test "$icu_version" -lt "4000"; then | 67 | - dnl If pkg-config fails for some reason, revert to the old method |
54 | - AC_MSG_ERROR([ICU version 4.0 or later is required]) | 68 | - if test "$found_icu" = "no"; then |
69 | - if test "$PHP_ICU_DIR" = "DEFAULT"; then | ||
70 | - dnl Try to find icu-config | ||
71 | - AC_PATH_PROG(ICU_CONFIG, icu-config, no, [$PATH:/usr/local/bin]) | ||
72 | - else | ||
73 | - ICU_CONFIG="$PHP_ICU_DIR/bin/icu-config" | ||
55 | - fi | 74 | - fi |
75 | - | ||
76 | - dnl Trust icu-config to know better what the install prefix is.. | ||
77 | - icu_install_prefix=`$ICU_CONFIG --prefix 2> /dev/null` | ||
78 | - if test "$?" != "0" || test -z "$icu_install_prefix"; then | ||
79 | - AC_MSG_RESULT([not found]) | ||
80 | - AC_MSG_ERROR([Unable to detect ICU prefix or $ICU_CONFIG failed. Please verify ICU install prefix and make sure icu-config works.]) | ||
81 | - else | ||
82 | - AC_MSG_RESULT([$icu_install_prefix]) | ||
83 | - | ||
84 | - dnl Check ICU version | ||
85 | - AC_MSG_CHECKING([for ICU 4.0 or greater]) | ||
86 | - icu_version_full=`$ICU_CONFIG --version` | ||
87 | - ac_IFS=$IFS | ||
88 | - IFS="." | ||
89 | - set $icu_version_full | ||
90 | - IFS=$ac_IFS | ||
91 | - icu_version=`expr [$]1 \* 1000 + [$]2` | ||
92 | - AC_MSG_RESULT([found $icu_version_full]) | ||
93 | - | ||
94 | - if test "$icu_version" -lt "4000"; then | ||
95 | - AC_MSG_ERROR([ICU version 4.0 or later is required]) | ||
96 | - fi | ||
97 | - | ||
98 | - ICU_VERSION=$icu_version | ||
99 | - ICU_INCS=`$ICU_CONFIG --cppflags-searchpath` | ||
100 | - ICU_LIBS=`$ICU_CONFIG --ldflags --ldflags-icuio` | ||
101 | - PHP_EVAL_INCLINE($ICU_INCS) | ||
102 | - PHP_EVAL_LIBLINE($ICU_LIBS, $1) | ||
103 | - | ||
104 | - ICU_CXXFLAGS=`$ICU_CONFIG --cxxflags` | ||
105 | - if test "$icu_version" -ge "49000"; then | ||
106 | - ICU_CXXFLAGS="$ICU_CXXFLAGS -DUNISTR_FROM_CHAR_EXPLICIT=explicit -DUNISTR_FROM_STRING_EXPLICIT=explicit" | ||
107 | - ICU_CFLAGS="-DU_NO_DEFAULT_INCLUDE_UTF_HEADERS=1" | ||
108 | - fi | ||
109 | - if test "$icu_version" -ge "60000"; then | ||
110 | - ICU_CFLAGS="$ICU_CFLAGS -DU_HIDE_OBSOLETE_UTF_OLD_H=1" | ||
111 | - fi | ||
112 | - fi | ||
113 | + PKG_CHECK_MODULES([ICU], [icu-io >= 50.1]) | ||
56 | + PHP_EVAL_INCLINE($ICU_CFLAGS) | 114 | + PHP_EVAL_INCLINE($ICU_CFLAGS) |
57 | + PHP_EVAL_LIBLINE($ICU_LIBS, $1) | 115 | + PHP_EVAL_LIBLINE($ICU_LIBS, $1) |
58 | 116 | + | |
59 | - ICU_VERSION=$icu_version | ||
60 | - ICU_INCS=`$ICU_CONFIG --cppflags-searchpath` | ||
61 | - ICU_LIBS=`$ICU_CONFIG --ldflags --ldflags-icuio` | ||
62 | - PHP_EVAL_INCLINE($ICU_INCS) | ||
63 | - PHP_EVAL_LIBLINE($ICU_LIBS, $1) | ||
64 | + ICU_CFLAGS="$ICU_CFLAGS -DU_NO_DEFAULT_INCLUDE_UTF_HEADERS=1" | 117 | + ICU_CFLAGS="$ICU_CFLAGS -DU_NO_DEFAULT_INCLUDE_UTF_HEADERS=1" |
65 | + ICU_CXXFLAGS="$ICU_CXXFLAGS -DUNISTR_FROM_CHAR_EXPLICIT=explicit -DUNISTR_FROM_STRING_EXPLICIT=explicit" | 118 | + ICU_CXXFLAGS="$ICU_CXXFLAGS -DUNISTR_FROM_CHAR_EXPLICIT=explicit -DUNISTR_FROM_STRING_EXPLICIT=explicit" |
66 | 119 | + | |
67 | - ICU_CXXFLAGS=`$ICU_CONFIG --cxxflags` | ||
68 | - if test "$icu_version" -ge "49000"; then | ||
69 | - ICU_CXXFLAGS="$ICU_CXXFLAGS -DUNISTR_FROM_CHAR_EXPLICIT=explicit -DUNISTR_FROM_STRING_EXPLICIT=explicit" | ||
70 | - ICU_CFLAGS="-DU_NO_DEFAULT_INCLUDE_UTF_HEADERS=1" | ||
71 | - fi | ||
72 | - if test "$icu_version" -ge "60000"; then | ||
73 | - ICU_CFLAGS="$ICU_CFLAGS -DU_HIDE_OBSOLETE_UTF_OLD_H=1" | ||
74 | - fi | ||
75 | + if $PKG_CONFIG icu-io --atleast-version=60; then | 120 | + if $PKG_CONFIG icu-io --atleast-version=60; then |
76 | + ICU_CFLAGS="$ICU_CFLAGS -DU_HIDE_OBSOLETE_UTF_OLD_H=1" | 121 | + ICU_CFLAGS="$ICU_CFLAGS -DU_HIDE_OBSOLETE_UTF_OLD_H=1" |
77 | fi | 122 | fi |
78 | ]) | 123 | ]) |
79 | 124 | ||
80 | --- php7.3.orig/ext/intl/config.m4 | 125 | diff --git a/ext/intl/config.m4 b/ext/intl/config.m4 |
81 | +++ php7.3/ext/intl/config.m4 | 126 | index 4b9f469..fdae88a 100644 |
127 | --- a/ext/intl/config.m4 | ||
128 | +++ b/ext/intl/config.m4 | ||
82 | @@ -9,15 +9,7 @@ if test "$PHP_INTL" != "no"; then | 129 | @@ -9,15 +9,7 @@ if test "$PHP_INTL" != "no"; then |
83 | PHP_SETUP_ICU(INTL_SHARED_LIBADD) | 130 | PHP_SETUP_ICU(INTL_SHARED_LIBADD) |
84 | PHP_SUBST(INTL_SHARED_LIBADD) | 131 | PHP_SUBST(INTL_SHARED_LIBADD) |
@@ -109,3 +156,6 @@ because icu-config is deprecated. | |||
109 | 156 | ||
110 | PHP_INTL_CXX_SOURCES="intl_convertcpp.cpp \ | 157 | PHP_INTL_CXX_SOURCES="intl_convertcpp.cpp \ |
111 | common/common_enum.cpp \ | 158 | common/common_enum.cpp \ |
159 | -- | ||
160 | 2.7.4 | ||
161 | |||
diff --git a/meta-oe/recipes-devtools/php/php_7.3.2.bb b/meta-oe/recipes-devtools/php/php_7.3.4.bb index 634facd4a0..1a5c9760de 100644 --- a/meta-oe/recipes-devtools/php/php_7.3.2.bb +++ b/meta-oe/recipes-devtools/php/php_7.3.4.bb | |||
@@ -13,8 +13,8 @@ SRC_URI_append_class-target = " \ | |||
13 | file://0001-opcache-config.m4-enable-opcache.patch \ | 13 | file://0001-opcache-config.m4-enable-opcache.patch \ |
14 | " | 14 | " |
15 | 15 | ||
16 | SRC_URI[md5sum] = "c893ff828945c274d90e026528142439" | 16 | SRC_URI[md5sum] = "efb58aea95a66738d871f83ec55fec6f" |
17 | SRC_URI[sha256sum] = "946f50dacbd2f61e643bb737021cbe8b1816e780ee7ad3e0cd999a1892ab0add" | 17 | SRC_URI[sha256sum] = "2e2c3d8212c83649e443b61efffbd03df4b9edd0f9c7a679081fe4cb2da12b78" |
18 | 18 | ||
19 | PACKAGECONFIG[mysql] = "--with-mysqli=mysqlnd \ | 19 | PACKAGECONFIG[mysql] = "--with-mysqli=mysqlnd \ |
20 | --with-pdo-mysql=mysqlnd \ | 20 | --with-pdo-mysql=mysqlnd \ |