summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/pocketpy/pocketpy_2.0.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/pocketpy/pocketpy_2.0.2.bb b/meta-oe/recipes-devtools/pocketpy/pocketpy_2.0.2.bb
new file mode 100644
index 0000000000..28ac67d8d6
--- /dev/null
+++ b/meta-oe/recipes-devtools/pocketpy/pocketpy_2.0.2.bb
@@ -0,0 +1,32 @@
1SUMMARY = "A Portable Python 3.x Interpreter in Modern C."
2DESCRIPTION = "pkpy is a lightweight(~15K LOC) Python 3.x \
3 interpreter for game scripting, written in C11. \
4 It aims to be an alternative to lua for game \
5 scripting, with elegant syntax, powerful features \
6 and competitive performance. pkpy is extremely \
7 easy to embed via a single header file pocketpy.h, \
8 without external dependencies. \
9 "
10HOMEPAGE = "https://pocketpy.dev/"
11BUGTRACKER = "https://github.com/pocketpy/pocketpy/issues"
12
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=8cdfa87bc5e09bc07f8cf64135026d91"
15
16SRC_URI = "git://github.com/pocketpy/pocketpy.git;protocol=https;branch=main"
17SRCREV = "b5a443efa11e7d6576025d1b9a397ead9e9260c9"
18
19S = "${WORKDIR}/git"
20
21inherit cmake
22
23do_install() {
24 install -d ${D}${libdir}
25 install -m 0644 ${B}/libpocketpy.so ${D}${libdir}/
26 install -d ${D}${includedir}/pocketpy
27 cp -r ${S}/include/* ${D}${includedir}/pocketpy/
28}
29
30FILES:${PN} = "${libdir}/libpocketpy.so"
31FILES:${PN}-dev = "${includedir}/pocketpy"
32FILES:${PN}-dbg += "${libdir}/.debug/libpocketpy.so"