diff options
-rw-r--r-- | meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch | 31 | ||||
-rw-r--r-- | meta-python/recipes-extended/python-meh/python3-meh_0.51.bb (renamed from meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb) | 7 |
2 files changed, 3 insertions, 35 deletions
diff --git a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch deleted file mode 100644 index 2eb6be5a18..0000000000 --- a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | From 034ac41561409ffc7836683331b6b94a641436e4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <tim.orling@konsulko.com> | ||
3 | Date: Mon, 28 Feb 2022 09:41:02 -0800 | ||
4 | Subject: [PATCH] setup.py: switch from distutils to setuptools | ||
5 | |||
6 | In Python 3.10 'distutils' is deprecated with removal slated for Python | ||
7 | 3.12. Switch from 'distutils.core' to 'setuptools'. | ||
8 | |||
9 | This also allows for a 'wheel' binary archive format to be built with | ||
10 | 'setup.py bdist_wheel'. | ||
11 | |||
12 | Upstream-Status: Backport [cf9eafdd165347f86bb4a2534c41fd805db52322] | ||
13 | |||
14 | Signed-off-by: Tim Orling <tim.orling@konsulko.com> | ||
15 | |||
16 | --- | ||
17 | setup.py | 2 +- | ||
18 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
19 | |||
20 | diff --git a/setup.py b/setup.py | ||
21 | index 9c12180..3ba5195 100644 | ||
22 | --- a/setup.py | ||
23 | +++ b/setup.py | ||
24 | @@ -1,6 +1,6 @@ | ||
25 | #!/usr/bin/python3 | ||
26 | |||
27 | -from distutils.core import setup | ||
28 | +from setuptools import setup | ||
29 | |||
30 | setup(name='python-meh', version='0.50.1', | ||
31 | description='Python module for handling exceptions', | ||
diff --git a/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb b/meta-python/recipes-extended/python-meh/python3-meh_0.51.bb index 1d9af438da..e83514af1b 100644 --- a/meta-python/recipes-extended/python-meh/python3-meh_0.50.1.bb +++ b/meta-python/recipes-extended/python-meh/python3-meh_0.51.bb | |||
@@ -9,9 +9,8 @@ inherit setuptools3_legacy | |||
9 | 9 | ||
10 | S = "${WORKDIR}/git" | 10 | S = "${WORKDIR}/git" |
11 | 11 | ||
12 | SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=rhel9-branch \ | 12 | SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=master" |
13 | file://0001-setup.py-switch-from-distutils-to-setuptools.patch \ | 13 | |
14 | " | 14 | SRCREV = "eb5d4adc3b838704b6a68f0f77ada2063a11ab1b" |
15 | SRCREV = "c321ce22950aff76611a3c6beffa02b5ea3adbed" | ||
16 | 15 | ||
17 | FILES:${PN} += "${datadir}/python-meh" | 16 | FILES:${PN} += "${datadir}/python-meh" |