summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/0001-free_mon-Include-missing-cstdint.patch26
-rw-r--r--meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb1
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/0001-free_mon-Include-missing-cstdint.patch b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/0001-free_mon-Include-missing-cstdint.patch
new file mode 100644
index 0000000000..1373d1a794
--- /dev/null
+++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/0001-free_mon-Include-missing-cstdint.patch
@@ -0,0 +1,26 @@
1From 5d8218b8a1b5bc71e2a0cf543a000e194daba599 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 29 Jan 2023 17:15:30 -0800
4Subject: [PATCH] free_mon: Include missing <cstdint>
5
6gcc 13 moved some includes around and as a result <cstdint> is no
7longer transitively included [1]. Explicitly include it
8for uintXX_t.
9
10[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 src/mongo/db/free_mon/free_mon_options.h | 1 +
15 1 file changed, 1 insertion(+)
16
17--- a/src/mongo/db/free_mon/free_mon_options.h
18+++ b/src/mongo/db/free_mon/free_mon_options.h
19@@ -29,6 +29,7 @@
20
21 #pragma once
22
23+#include <cstdint>
24 #include <string>
25 #include <vector>
26
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
index 6e93ec9b0c..b4567d098a 100644
--- a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
+++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb
@@ -33,6 +33,7 @@ SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.4;protocol=https \
33 file://0001-add-explict-static_cast-size_t-to-maxMemoryUsageByte.patch \ 33 file://0001-add-explict-static_cast-size_t-to-maxMemoryUsageByte.patch \
34 file://0001-server-Adjust-the-cache-alignment-assumptions.patch \ 34 file://0001-server-Adjust-the-cache-alignment-assumptions.patch \
35 file://0001-The-std-lib-unary-binary_function-base-classes-are-d.patch \ 35 file://0001-The-std-lib-unary-binary_function-base-classes-are-d.patch \
36 file://0001-free_mon-Include-missing-cstdint.patch \
36 " 37 "
37SRC_URI:append:libc-musl ="\ 38SRC_URI:append:libc-musl ="\
38 file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \ 39 file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \