diff options
-rw-r--r-- | meta-oe/recipes-devtools/librcf/librcf/0001-ClientStub.hpp-fix-a-clang-compiling-issue.patch | 35 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb | 1 |
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/librcf/librcf/0001-ClientStub.hpp-fix-a-clang-compiling-issue.patch b/meta-oe/recipes-devtools/librcf/librcf/0001-ClientStub.hpp-fix-a-clang-compiling-issue.patch new file mode 100644 index 0000000000..e949dee40e --- /dev/null +++ b/meta-oe/recipes-devtools/librcf/librcf/0001-ClientStub.hpp-fix-a-clang-compiling-issue.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From d78851b6f87f2472f041102d7b3726ffc009bfad Mon Sep 17 00:00:00 2001 | ||
2 | From: Ming Liu <peter.x.liu@external.atlascopco.com> | ||
3 | Date: Tue, 6 Jun 2017 05:54:20 +0200 | ||
4 | Subject: [PATCH] ClientStub.hpp: fix a clang compiling issue | ||
5 | |||
6 | A error was observed with clang compiler, as follows: | ||
7 | | src/RCF/RCF.cpp:49: | ||
8 | | src/RCF/ClientStub.cpp:28: | ||
9 | | include/RCF/Future.hpp:49:26: error: 'enrol' is a private member of 'RCF::ClientStub' | ||
10 | |||
11 | it can be fixed by declaring Future as a friend class of ClientStub. | ||
12 | |||
13 | Upstream-Status: Pending | ||
14 | |||
15 | Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> | ||
16 | --- | ||
17 | include/RCF/ClientStub.hpp | 2 ++ | ||
18 | 1 file changed, 2 insertions(+) | ||
19 | |||
20 | diff --git a/include/RCF/ClientStub.hpp b/include/RCF/ClientStub.hpp | ||
21 | index 9882cf4..8465625 100755 | ||
22 | --- a/include/RCF/ClientStub.hpp | ||
23 | +++ b/include/RCF/ClientStub.hpp | ||
24 | @@ -372,6 +372,8 @@ namespace RCF { | ||
25 | |||
26 | private: | ||
27 | |||
28 | + template<typename U> | ||
29 | + friend class Future; | ||
30 | friend class FutureImplBase; | ||
31 | |||
32 | template< | ||
33 | -- | ||
34 | 2.7.4 | ||
35 | |||
diff --git a/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb b/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb index cf0a8e7b1c..4c9683a664 100644 --- a/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb +++ b/meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb | |||
@@ -13,6 +13,7 @@ LIC_FILES_CHKSUM = "file://license.txt;md5=7586a312b9e978f9d6fac9a5780d1f84" | |||
13 | SRC_URI = "http://www.deltavsoft.com/downloads/RCF-${PV}.tar.gz \ | 13 | SRC_URI = "http://www.deltavsoft.com/downloads/RCF-${PV}.tar.gz \ |
14 | file://0001-Add-CMake-build-files.patch \ | 14 | file://0001-Add-CMake-build-files.patch \ |
15 | file://aarch64-support.patch \ | 15 | file://aarch64-support.patch \ |
16 | file://0001-ClientStub.hpp-fix-a-clang-compiling-issue.patch \ | ||
16 | " | 17 | " |
17 | 18 | ||
18 | SRC_URI[md5sum] = "7ecb3c73f7eb66dba8790b659374f690" | 19 | SRC_URI[md5sum] = "7ecb3c73f7eb66dba8790b659374f690" |