diff options
-rw-r--r-- | meta-oe/recipes-test/bats/bats_1.5.0.bb (renamed from meta-oe/recipes-test/bats/bats_1.4.1.bb) | 6 | ||||
-rw-r--r-- | meta-oe/recipes-test/bats/files/0001-install.sh-consider-multilib.patch | 43 |
2 files changed, 2 insertions, 47 deletions
diff --git a/meta-oe/recipes-test/bats/bats_1.4.1.bb b/meta-oe/recipes-test/bats/bats_1.5.0.bb index 13babd5ea5..ffbb37c8a1 100644 --- a/meta-oe/recipes-test/bats/bats_1.4.1.bb +++ b/meta-oe/recipes-test/bats/bats_1.5.0.bb | |||
@@ -6,11 +6,9 @@ HOMEPAGE = "https://github.com/bats-core/bats-core" | |||
6 | LICENSE = "MIT" | 6 | LICENSE = "MIT" |
7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b" | 7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b" |
8 | 8 | ||
9 | SRC_URI = "git://github.com/bats-core/bats-core.git;branch=master;protocol=https \ | 9 | SRC_URI = "git://github.com/bats-core/bats-core.git;branch=master;protocol=https" |
10 | file://0001-install.sh-consider-multilib.patch \ | ||
11 | " | ||
12 | # v1.4.1 | 10 | # v1.4.1 |
13 | SRCREV = "54e965fa9d269c2b3ff9036d81f32bac3df0edea" | 11 | SRCREV = "99d64eb017abcd6a766dd0d354e625526da69cb3" |
14 | 12 | ||
15 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
16 | 14 | ||
diff --git a/meta-oe/recipes-test/bats/files/0001-install.sh-consider-multilib.patch b/meta-oe/recipes-test/bats/files/0001-install.sh-consider-multilib.patch deleted file mode 100644 index c7393ca2ed..0000000000 --- a/meta-oe/recipes-test/bats/files/0001-install.sh-consider-multilib.patch +++ /dev/null | |||
@@ -1,43 +0,0 @@ | |||
1 | From 6e3d01f1ff199383b78a7504858c374fbce05f4e Mon Sep 17 00:00:00 2001 | ||
2 | From: Kai Kang <kai.kang@windriver.com> | ||
3 | Date: Thu, 10 Jun 2021 11:11:07 +0800 | ||
4 | Subject: [PATCH] install.sh: consider multilib | ||
5 | |||
6 | It may install files to /usr/lib64 when multilib is enabled. Add an | ||
7 | optional parameter for install.sh to support it. | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/bats-core/bats-core/pull/452] | ||
10 | |||
11 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | ||
12 | --- | ||
13 | install.sh | 5 +++-- | ||
14 | 1 file changed, 3 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/install.sh b/install.sh | ||
17 | index e660866..d91159e 100755 | ||
18 | --- a/install.sh | ||
19 | +++ b/install.sh | ||
20 | @@ -4,6 +4,7 @@ set -e | ||
21 | |||
22 | BATS_ROOT="${0%/*}" | ||
23 | PREFIX="$1" | ||
24 | +BASELIB="${2:-lib}" | ||
25 | |||
26 | if [[ -z "$PREFIX" ]]; then | ||
27 | printf '%s\n' \ | ||
28 | @@ -12,10 +13,10 @@ if [[ -z "$PREFIX" ]]; then | ||
29 | exit 1 | ||
30 | fi | ||
31 | |||
32 | -install -d -m 755 "$PREFIX"/{bin,libexec/bats-core,lib/bats-core,share/man/man{1,7}} | ||
33 | +install -d -m 755 "$PREFIX"/{bin,libexec/bats-core,${BASELIB}/bats-core,share/man/man{1,7}} | ||
34 | install -m 755 "$BATS_ROOT/bin"/* "$PREFIX/bin" | ||
35 | install -m 755 "$BATS_ROOT/libexec/bats-core"/* "$PREFIX/libexec/bats-core" | ||
36 | -install -m 755 "$BATS_ROOT/lib/bats-core"/* "$PREFIX/lib/bats-core" | ||
37 | +install -m 755 "$BATS_ROOT/lib/bats-core"/* "$PREFIX/${BASELIB}/bats-core" | ||
38 | install -m 644 "$BATS_ROOT/man/bats.1" "$PREFIX/share/man/man1" | ||
39 | install -m 644 "$BATS_ROOT/man/bats.7" "$PREFIX/share/man/man7" | ||
40 | |||
41 | -- | ||
42 | 2.17.1 | ||
43 | |||