diff options
-rw-r--r-- | meta-oe/recipes-support/hddtemp/hddtemp/0001-backtrace-Replace-struct-ucontext-with-ucontext_t.patch | 37 | ||||
-rw-r--r-- | meta-oe/recipes-support/hddtemp/hddtemp_0.3-beta15.bb | 1 |
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/hddtemp/hddtemp/0001-backtrace-Replace-struct-ucontext-with-ucontext_t.patch b/meta-oe/recipes-support/hddtemp/hddtemp/0001-backtrace-Replace-struct-ucontext-with-ucontext_t.patch new file mode 100644 index 0000000000..cfffa2ed09 --- /dev/null +++ b/meta-oe/recipes-support/hddtemp/hddtemp/0001-backtrace-Replace-struct-ucontext-with-ucontext_t.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From d195f8cfe41991573128ccdcd3a0ed0267aa5e33 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 28 Jun 2017 19:44:46 -0700 | ||
4 | Subject: [PATCH] backtrace: Replace struct ucontext with ucontext_t | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | src/backtrace.c | 4 ++-- | ||
11 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
12 | |||
13 | diff --git a/src/backtrace.c b/src/backtrace.c | ||
14 | index 69bee99..dc35f8f 100644 | ||
15 | --- a/src/backtrace.c | ||
16 | +++ b/src/backtrace.c | ||
17 | @@ -42,7 +42,7 @@ | ||
18 | #define MAX_BTSIZE 64 | ||
19 | |||
20 | void backtrace_handler(int n, siginfo_t *ist, void *extra) { | ||
21 | - static struct ucontext *puc; | ||
22 | + static ucontext_t *puc; | ||
23 | static void *btinfo[MAX_BTSIZE]; | ||
24 | static char **messages = NULL; | ||
25 | static size_t btsize = 0; | ||
26 | @@ -58,7 +58,7 @@ void backtrace_handler(int n, siginfo_t *ist, void *extra) { | ||
27 | |||
28 | #define SIC_CASE(c) case c: strerr = #c | ||
29 | |||
30 | - puc = (struct ucontext *)extra; | ||
31 | + puc = (ucontext_t *)extra; | ||
32 | switch(n) { | ||
33 | case SIGSEGV: | ||
34 | switch(ist->si_code) { | ||
35 | -- | ||
36 | 2.13.2 | ||
37 | |||
diff --git a/meta-oe/recipes-support/hddtemp/hddtemp_0.3-beta15.bb b/meta-oe/recipes-support/hddtemp/hddtemp_0.3-beta15.bb index 601b7b1151..4a871bf4f4 100644 --- a/meta-oe/recipes-support/hddtemp/hddtemp_0.3-beta15.bb +++ b/meta-oe/recipes-support/hddtemp/hddtemp_0.3-beta15.bb | |||
@@ -8,6 +8,7 @@ SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/hddtemp/hddtemp-0.3-beta15.tar.bz2 \ | |||
8 | file://hddtemp-no-nls-support.patch \ | 8 | file://hddtemp-no-nls-support.patch \ |
9 | file://hddtemp_0.3-beta15-52.diff \ | 9 | file://hddtemp_0.3-beta15-52.diff \ |
10 | file://hddtemp-0.3-beta15-autodetect-717479.patch \ | 10 | file://hddtemp-0.3-beta15-autodetect-717479.patch \ |
11 | file://0001-backtrace-Replace-struct-ucontext-with-ucontext_t.patch \ | ||
11 | file://hddtemp.db \ | 12 | file://hddtemp.db \ |
12 | file://init \ | 13 | file://init \ |
13 | " | 14 | " |