diff options
-rw-r--r-- | meta-oe/recipes-support/libssh2/files/run-ptest | 7 | ||||
-rw-r--r-- | meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb | 17 |
2 files changed, 23 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libssh2/files/run-ptest b/meta-oe/recipes-support/libssh2/files/run-ptest new file mode 100644 index 0000000000..2a7922f1aa --- /dev/null +++ b/meta-oe/recipes-support/libssh2/files/run-ptest | |||
@@ -0,0 +1,7 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | ptestdir=$(dirname "$(readlink -f "$0")") | ||
4 | for test in $(ls $ptestdir/tests) | ||
5 | do | ||
6 | ./test-driver --test-name $test --log-file $test.log --trs-file $test.trs --color-tests no --enable-hard-errors yes --expect-failure no -- ./tests/$test | ||
7 | done | ||
diff --git a/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb b/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb index c1f337a440..a1d85617a6 100644 --- a/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb +++ b/meta-oe/recipes-support/libssh2/libssh2_1.9.0.bb | |||
@@ -9,11 +9,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c5cf34fc0acb44b082ef50ef5e4354ca" | |||
9 | 9 | ||
10 | SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz \ | 10 | SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz \ |
11 | file://CVE-2019-17498.patch \ | 11 | file://CVE-2019-17498.patch \ |
12 | file://run-ptest \ | ||
12 | " | 13 | " |
13 | SRC_URI[md5sum] = "1beefafe8963982adc84b408b2959927" | 14 | SRC_URI[md5sum] = "1beefafe8963982adc84b408b2959927" |
14 | SRC_URI[sha256sum] = "d5fb8bd563305fd1074dda90bd053fb2d29fc4bce048d182f96eaa466dfadafd" | 15 | SRC_URI[sha256sum] = "d5fb8bd563305fd1074dda90bd053fb2d29fc4bce048d182f96eaa466dfadafd" |
15 | 16 | ||
16 | inherit autotools pkgconfig | 17 | inherit autotools pkgconfig ptest |
17 | 18 | ||
18 | EXTRA_OECONF += "\ | 19 | EXTRA_OECONF += "\ |
19 | --with-libz \ | 20 | --with-libz \ |
@@ -26,3 +27,17 @@ PACKAGECONFIG[openssl] = "--with-crypto=openssl --with-libssl-prefix=${STAGING_L | |||
26 | PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR}, , libgcrypt" | 27 | PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR}, , libgcrypt" |
27 | 28 | ||
28 | BBCLASSEXTEND = "native nativesdk" | 29 | BBCLASSEXTEND = "native nativesdk" |
30 | |||
31 | RDEPENDS_${PN}-ptest = "bash" | ||
32 | |||
33 | do_compile_ptest() { | ||
34 | sed -i "/\$(MAKE) \$(AM_MAKEFLAGS) check-TESTS/d" tests/Makefile | ||
35 | oe_runmake check | ||
36 | } | ||
37 | |||
38 | do_install_ptest() { | ||
39 | install -d ${D}${PTEST_PATH}/tests | ||
40 | install -m 0755 ${B}/tests/.libs/simple ${D}${PTEST_PATH}/tests/ | ||
41 | install -m 0755 ${S}/tests/mansyntax.sh ${D}${PTEST_PATH}/tests/ | ||
42 | install -m 0755 ${S}/test-driver ${D}${PTEST_PATH}/ | ||
43 | } | ||