summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-devtools/msgpack/msgpack-c/0001-Comment-intentional-fallthrough-in-case-statements.patch39
-rw-r--r--meta-oe/recipes-devtools/msgpack/msgpack-c_2.1.5.bb (renamed from meta-oe/recipes-devtools/msgpack/msgpack-c_2.1.1.bb)3
2 files changed, 1 insertions, 41 deletions
diff --git a/meta-oe/recipes-devtools/msgpack/msgpack-c/0001-Comment-intentional-fallthrough-in-case-statements.patch b/meta-oe/recipes-devtools/msgpack/msgpack-c/0001-Comment-intentional-fallthrough-in-case-statements.patch
deleted file mode 100644
index a388297a86..0000000000
--- a/meta-oe/recipes-devtools/msgpack/msgpack-c/0001-Comment-intentional-fallthrough-in-case-statements.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 15d8bb6792c9639d85a9ffe2ac81431f1b986c21 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 22 Apr 2017 08:53:50 -0700
4Subject: [PATCH] Comment intentional fallthrough in case statements
5
6Fixes build with gcc7
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 include/msgpack/v1/adaptor/detail/cpp03_define_array.hpp | 4 ++++
11 1 file changed, 4 insertions(+)
12
13diff --git a/include/msgpack/v1/adaptor/detail/cpp03_define_array.hpp b/include/msgpack/v1/adaptor/detail/cpp03_define_array.hpp
14index b35c21a7..4c463a90 100644
15--- a/include/msgpack/v1/adaptor/detail/cpp03_define_array.hpp
16+++ b/include/msgpack/v1/adaptor/detail/cpp03_define_array.hpp
17@@ -105,6 +105,7 @@ struct define_array<A0, A1> {
18 switch(size) {
19 default:
20 case 2: ptr[1].convert(a1);
21+ //fallthrough
22 case 1: ptr[0].convert(a0);
23 }
24 }
25@@ -193,8 +194,11 @@ struct define_array<A0, A1, A2, A3> {
26 switch(size) {
27 default:
28 case 4: ptr[3].convert(a3);
29+ //fallthrough
30 case 3: ptr[2].convert(a2);
31+ //fallthrough
32 case 2: ptr[1].convert(a1);
33+ //fallthrough
34 case 1: ptr[0].convert(a0);
35 }
36 }
37--
382.12.2
39
diff --git a/meta-oe/recipes-devtools/msgpack/msgpack-c_2.1.1.bb b/meta-oe/recipes-devtools/msgpack/msgpack-c_2.1.5.bb
index 7655d94698..d9f6956690 100644
--- a/meta-oe/recipes-devtools/msgpack/msgpack-c_2.1.1.bb
+++ b/meta-oe/recipes-devtools/msgpack/msgpack-c_2.1.5.bb
@@ -9,10 +9,9 @@ LIC_FILES_CHKSUM = "file://NOTICE;md5=7a858c074723608e08614061dc044352 \
9 9
10PV .= "+git${SRCPV}" 10PV .= "+git${SRCPV}"
11 11
12SRCREV = "20ef1f925b007f170ab1c257e4aa61fdd0927773" 12SRCREV = "7a98138f27f27290e680bf8fbf1f8d1b089bf138"
13 13
14SRC_URI = "git://github.com/msgpack/msgpack-c \ 14SRC_URI = "git://github.com/msgpack/msgpack-c \
15 file://0001-Comment-intentional-fallthrough-in-case-statements.patch \
16 " 15 "
17 16
18inherit cmake pkgconfig 17inherit cmake pkgconfig