summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch13
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio-tools_1.70.0.bb (renamed from meta-python/recipes-devtools/python/python3-grpcio-tools_1.69.0.bb)2
2 files changed, 9 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
index 5366a1e1cf..439b337bda 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
+++ b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -27,7 +27,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
27 1 file changed, 6 insertions(+), 4 deletions(-) 27 1 file changed, 6 insertions(+), 4 deletions(-)
28 28
29diff --git a/setup.py b/setup.py 29diff --git a/setup.py b/setup.py
30index 5e19b63..61b30d8 100644 30index 1a997df..86e3ad1 100644
31--- a/setup.py 31--- a/setup.py
32+++ b/setup.py 32+++ b/setup.py
33@@ -90,9 +90,11 @@ def check_linker_need_libatomic(): 33@@ -90,9 +90,11 @@ def check_linker_need_libatomic():
@@ -36,12 +36,12 @@ index 5e19b63..61b30d8 100644
36 ) 36 )
37- cxx = os.environ.get("CXX", "c++") 37- cxx = os.environ.get("CXX", "c++")
38- cpp_test = subprocess.Popen( 38- cpp_test = subprocess.Popen(
39- [cxx, "-x", "c++", "-std=c++14", "-"], 39- [cxx, "-x", "c++", "-std=c++17", "-"],
40+ cxx, cxx_args = os.environ.get('CXX').split(' ', 1) or 'c++' 40+ cxx, cxx_args = os.environ.get('CXX').split(' ', 1) or 'c++'
41+ if not cxx_args: 41+ if not cxx_args:
42+ cxx_args = "-g" 42+ cxx_args = "-g"
43+ 43+
44+ cpp_test = subprocess.Popen([cxx, cxx_args, '-x', 'c++', '-std=c++14', '-'], 44+ cpp_test = subprocess.Popen([cxx, cxx_args, '-x', 'c++', '-std=c++17', '-'],
45 stdin=PIPE, 45 stdin=PIPE,
46 stdout=PIPE, 46 stdout=PIPE,
47 stderr=PIPE, 47 stderr=PIPE,
@@ -49,8 +49,11 @@ index 5e19b63..61b30d8 100644
49 # Double-check to see if -latomic actually can solve the problem. 49 # Double-check to see if -latomic actually can solve the problem.
50 # https://github.com/grpc/grpc/issues/22491 50 # https://github.com/grpc/grpc/issues/22491
51 cpp_test = subprocess.Popen( 51 cpp_test = subprocess.Popen(
52- [cxx, "-x", "c++", "-std=c++14", "-", "-latomic"], 52- [cxx, "-x", "c++", "-std=c++17", "-", "-latomic"],
53+ [cxx, cxx_args, '-x', 'c++', '-std=c++14', '-', '-latomic'], 53+ [cxx, cxx_args, '-x', 'c++', '-std=c++17', '-', '-latomic'],
54 stdin=PIPE, 54 stdin=PIPE,
55 stdout=PIPE, 55 stdout=PIPE,
56 stderr=PIPE, 56 stderr=PIPE,
57--
582.43.0
59
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools_1.69.0.bb b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.70.0.bb
index 76f5739f95..e295e0329e 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio-tools_1.69.0.bb
+++ b/meta-python/recipes-devtools/python/python3-grpcio-tools_1.70.0.bb
@@ -15,7 +15,7 @@ DEPENDS += "python3-grpcio"
15SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \ 15SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch \
16 file://0001-protobuf-Disable-musttail-attribute-on-mips.patch \ 16 file://0001-protobuf-Disable-musttail-attribute-on-mips.patch \
17 " 17 "
18SRC_URI[sha256sum] = "3e1a98f4d9decb84979e1ddd3deb09c0a33a84b6e3c0776d5bde4097e3ab66dd" 18SRC_URI[sha256sum] = "e578fee7c1c213c8e471750d92631d00f178a15479fb2cb3b939a07fc125ccd3"
19 19
20RDEPENDS:${PN} = "python3-grpcio" 20RDEPENDS:${PN} = "python3-grpcio"
21 21