summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-pytest-asyncio.inc13
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb15
2 files changed, 13 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest-asyncio.inc b/meta-python/recipes-devtools/python/python-pytest-asyncio.inc
deleted file mode 100644
index 9132c7452c..0000000000
--- a/meta-python/recipes-devtools/python/python-pytest-asyncio.inc
+++ /dev/null
@@ -1,13 +0,0 @@
1DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python, for testing asyncio code with pytest"
2HOMEPAGE = "https://github.com/pytest-dev/pytest-asyncio"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://README.rst;md5=ae62268d207c73b615fbefddaf91a881"
5
6SRC_URI[md5sum] = "247a7ec32f24a185341327c42a0f85bf"
7SRC_URI[sha256sum] = "9fac5100fd716cbecf6ef89233e8590a4ad61d729d1732e0a96b84182df1daaf"
8
9inherit pypi
10
11DEPENDS += "${PYTHON_PN}-pytest-native"
12
13BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
index 09f26f8d15..a7e963b044 100644
--- a/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pytest-asyncio_0.10.0.bb
@@ -1,2 +1,13 @@
1inherit setuptools3 1DESCRIPTION = "pytest-asyncio is an Apache2 licensed library, written in Python, for testing asyncio code with pytest"
2require python-pytest-asyncio.inc 2HOMEPAGE = "https://github.com/pytest-dev/pytest-asyncio"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://README.rst;md5=ae62268d207c73b615fbefddaf91a881"
5
6SRC_URI[md5sum] = "247a7ec32f24a185341327c42a0f85bf"
7SRC_URI[sha256sum] = "9fac5100fd716cbecf6ef89233e8590a4ad61d729d1732e0a96b84182df1daaf"
8
9inherit pypi setuptools3
10
11DEPENDS += "${PYTHON_PN}-pytest-native"
12
13BBCLASSEXTEND = "native"