summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-graphics/ftgl/ftgl/0001-Explicit-typecast-to-avoid-implicit-double-to-float-.patch38
-rw-r--r--meta-oe/recipes-graphics/ftgl/ftgl/0001-Fix-type-mismatch-with-latest-FreeType.patch33
-rw-r--r--meta-oe/recipes-graphics/ftgl/ftgl/0001-use-pkg-config-to-find-freetype2.patch38
-rw-r--r--meta-oe/recipes-graphics/ftgl/ftgl/0002-Makefile.am-remove-useless-and-breaking-code.patch38
-rw-r--r--meta-oe/recipes-graphics/ftgl/ftgl_2.1.3-rc5.bb27
-rw-r--r--meta-oe/recipes-graphics/ftgl/ftgl_2.4.0.bb20
6 files changed, 53 insertions, 141 deletions
diff --git a/meta-oe/recipes-graphics/ftgl/ftgl/0001-Explicit-typecast-to-avoid-implicit-double-to-float-.patch b/meta-oe/recipes-graphics/ftgl/ftgl/0001-Explicit-typecast-to-avoid-implicit-double-to-float-.patch
deleted file mode 100644
index 385bff8dd1..0000000000
--- a/meta-oe/recipes-graphics/ftgl/ftgl/0001-Explicit-typecast-to-avoid-implicit-double-to-float-.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From e3bce98a60d6db3b719bbf5d71f732f9b86cb566 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 9 Feb 2019 08:28:09 -0800
4Subject: [PATCH] Explicit typecast to avoid implicit double to float
5 conversion
6
7fixes compile errors e.g.
8
9../../ftgl-2.1.3~rc5/demo/simple.cpp:110:27: error: non-constant-expression cannot be narrowed from type 'double' to
10 'float' in initializer list [-Wc++11-narrowing]
11 (t3 + 2.0) / 3, 0.3 };
12 ^~~~~~~~~~~~~~
13Upstream-Status: Pending
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 demo/simple.cpp | 6 +++---
17 1 file changed, 3 insertions(+), 3 deletions(-)
18
19diff --git a/demo/simple.cpp b/demo/simple.cpp
20index 532e862..aba55b4 100644
21--- a/demo/simple.cpp
22+++ b/demo/simple.cpp
23@@ -105,9 +105,9 @@ static void RenderScene(void)
24 float t2 = sin(n / 50 + 1);
25 float t3 = sin(n / 30 + 2);
26
27- float ambient[4] = { (t1 + 2.0) / 3,
28- (t2 + 2.0) / 3,
29- (t3 + 2.0) / 3, 0.3 };
30+ float ambient[4] = { float(t1 + 2.0) / 3,
31+ float(t2 + 2.0) / 3,
32+ float(t3 + 2.0) / 3, 0.3 };
33 float diffuse[4] = { 1.0, 0.9, 0.9, 1.0 };
34 float specular[4] = { 1.0, 0.7, 0.7, 1.0 };
35 float position[4] = { 100.0, 100.0, 0.0, 1.0 };
36--
372.20.1
38
diff --git a/meta-oe/recipes-graphics/ftgl/ftgl/0001-Fix-type-mismatch-with-latest-FreeType.patch b/meta-oe/recipes-graphics/ftgl/ftgl/0001-Fix-type-mismatch-with-latest-FreeType.patch
new file mode 100644
index 0000000000..e481e4e793
--- /dev/null
+++ b/meta-oe/recipes-graphics/ftgl/ftgl/0001-Fix-type-mismatch-with-latest-FreeType.patch
@@ -0,0 +1,33 @@
1From d11219b681a080c71e33c51c9404c28b134e1745 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 21 Aug 2024 13:50:34 -0700
4Subject: [PATCH] Fix type mismatch with latest FreeType
5
6This change is intrumented due to a type change in freetype [1] with release 2.13.3
7
8Fixes
9| ../../git/src/FTVectoriser.cpp:171:15: error: cannot initialize a variable of type 'char *' with an rvalue of type 'unsigned char *'
10| 171 | char* tagList = &outline.tags[startIndex];
11| | ^ ~~~~~~~~~~~~~~~~~~~~~~~~~
12
13[1] https://gitlab.freedesktop.org/freetype/freetype/-/commit/044d142be7b6a93b6940367a1bc5847451ff4775
14
15Upstream-Status: Submitted [https://github.com/frankheckenbach/ftgl/pull/19]
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 src/FTVectoriser.cpp | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/src/FTVectoriser.cpp b/src/FTVectoriser.cpp
22index 26e7da8..3610215 100644
23--- a/src/FTVectoriser.cpp
24+++ b/src/FTVectoriser.cpp
25@@ -168,7 +168,7 @@ void FTVectoriser::ProcessContours()
26 for(int i = 0; i < ftContourCount; ++i)
27 {
28 FT_Vector* pointList = &outline.points[startIndex];
29- char* tagList = &outline.tags[startIndex];
30+ char* tagList = (char*)&outline.tags[startIndex];
31
32 endIndex = outline.contours[i];
33 contourLength = (endIndex - startIndex) + 1;
diff --git a/meta-oe/recipes-graphics/ftgl/ftgl/0001-use-pkg-config-to-find-freetype2.patch b/meta-oe/recipes-graphics/ftgl/ftgl/0001-use-pkg-config-to-find-freetype2.patch
deleted file mode 100644
index e5ed0bdb86..0000000000
--- a/meta-oe/recipes-graphics/ftgl/ftgl/0001-use-pkg-config-to-find-freetype2.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From 8bb183926078b6dd54048fb6820838fe7b6e6163 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Sun, 23 Oct 2016 22:46:43 +0200
4Subject: [PATCH] use pkg-config to find freetype2
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Inappropriate [OE specific]
10
11Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
12---
13 configure.ac | 9 +++++++--
14 1 file changed, 7 insertions(+), 2 deletions(-)
15
16diff --git a/configure.ac b/configure.ac
17index 53560ea..b5bb6a3 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -41,8 +41,13 @@ AC_CHECK_FUNCS(strndup)
21
22 AC_PATH_X
23
24-AC_CHECK_FT2([9.0.3],[],
25- [AC_MSG_ERROR([FreeType2 is required to compile this library])])
26+PKG_CHECK_MODULES(FT2, freetype2,
27+ CFLAGS="$CFLAGS $FT2_CFLAGS"
28+ LIBS="$LIBS $FT2_LIBS",
29+ AC_MSG_ERROR([FreeType2 is required to compile this library])
30+)
31+AC_SUBST([FT2_CFLAGS])
32+AC_SUBST([FT2_LIBS])
33
34 AC_PATH_XTRA
35
36--
372.5.5
38
diff --git a/meta-oe/recipes-graphics/ftgl/ftgl/0002-Makefile.am-remove-useless-and-breaking-code.patch b/meta-oe/recipes-graphics/ftgl/ftgl/0002-Makefile.am-remove-useless-and-breaking-code.patch
deleted file mode 100644
index 830783e204..0000000000
--- a/meta-oe/recipes-graphics/ftgl/ftgl/0002-Makefile.am-remove-useless-and-breaking-code.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From daabb4110661c4358ec73293d5c0b2106f567c1f Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Sun, 23 Oct 2016 23:54:14 +0200
4Subject: [PATCH] Makefile.am: remove useless and breaking code
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Pending
10
11Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
12---
13 Makefile.am | 9 ---------
14 1 file changed, 9 deletions(-)
15
16diff --git a/Makefile.am b/Makefile.am
17index 89a8a7f..e582a34 100644
18--- a/Makefile.am
19+++ b/Makefile.am
20@@ -24,15 +24,6 @@ EXTRA_DIST = \
21 m4 \
22 $(NULL)
23
24-# Print out an informative summary.
25-all-local:
26- @$(ECHO) "Done."
27- @$(ECHO)
28- @if test "x$(MAKECMDGOALS)" = "xall-am" -o "x$(.TARGETS)" = "xall-am" -o "x$(MAKECMDGOALS)" = "x" -o "x$(.TARGETS)" = "x" ; then \
29- $(ECHO) "---" ;\
30- $(ECHO) "Run 'make install' to begin installation into $(prefix)" ;\
31- fi
32- @$(ECHO)
33
34 # Upload documentation
35 DOC = docs/html docs/latex/ftgl.pdf
36--
372.5.5
38
diff --git a/meta-oe/recipes-graphics/ftgl/ftgl_2.1.3-rc5.bb b/meta-oe/recipes-graphics/ftgl/ftgl_2.1.3-rc5.bb
deleted file mode 100644
index 65f72747cc..0000000000
--- a/meta-oe/recipes-graphics/ftgl/ftgl_2.1.3-rc5.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1SUMMARY = "OpenGL frontend to Freetype 2"
2HOMEPAGE = "https://sourceforge.net/projects/ftgl/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=527a83e92c7bf363025380eec05df6e4"
5
6inherit autotools pkgconfig features_check
7
8REQUIRED_DISTRO_FEATURES = "opengl x11"
9
10DEPENDS += " \
11 freetype \
12 freeglut \
13"
14
15SRC_URI = " \
16 ${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
17 file://0001-use-pkg-config-to-find-freetype2.patch \
18 file://0002-Makefile.am-remove-useless-and-breaking-code.patch \
19 file://0001-Explicit-typecast-to-avoid-implicit-double-to-float-.patch \
20"
21SRC_URI[md5sum] = "c7879018cde844059495b3029b0b6503"
22SRC_URI[sha256sum] = "521ff7bd62c459ff5372e269c223e2a6107a6a99a36afdc2ae634a973af70c59"
23
24S = "${WORKDIR}/ftgl-2.1.3~rc5"
25
26# undefined reference to symbol 'sin@@GLIBC_2.4'
27CFLAGS += "-lm"
diff --git a/meta-oe/recipes-graphics/ftgl/ftgl_2.4.0.bb b/meta-oe/recipes-graphics/ftgl/ftgl_2.4.0.bb
new file mode 100644
index 0000000000..85b0d68aa3
--- /dev/null
+++ b/meta-oe/recipes-graphics/ftgl/ftgl_2.4.0.bb
@@ -0,0 +1,20 @@
1SUMMARY = "OpenGL frontend to Freetype 2"
2HOMEPAGE = "https://sourceforge.net/projects/ftgl/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=527a83e92c7bf363025380eec05df6e4"
5
6inherit autotools pkgconfig features_check
7
8REQUIRED_DISTRO_FEATURES = "opengl x11"
9
10DEPENDS += " \
11 freetype \
12 freeglut \
13"
14SRCREV = "ddc77166651a71ae037ef3129a285440aa559b2d"
15PV .= "+git"
16
17SRC_URI = "git://github.com/frankheckenbach/ftgl;protocol=https;branch=master \
18 file://0001-Fix-type-mismatch-with-latest-FreeType.patch"
19
20S = "${WORKDIR}/git"