summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-hgfsmounter-Makefile.am-support-usrmerge.patch33
-rw-r--r--meta-oe/recipes-support/open-vm-tools/open-vm-tools_11.0.1.bb9
2 files changed, 40 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-hgfsmounter-Makefile.am-support-usrmerge.patch b/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-hgfsmounter-Makefile.am-support-usrmerge.patch
new file mode 100644
index 0000000000..82443ee660
--- /dev/null
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools/0001-hgfsmounter-Makefile.am-support-usrmerge.patch
@@ -0,0 +1,33 @@
1From 33798f3e484ebd3470e9da791b73b4b90ba12bc3 Mon Sep 17 00:00:00 2001
2From: Yi Zhao <yi.zhao@windriver.com>
3Date: Tue, 14 Jan 2020 15:04:03 +0800
4Subject: [PATCH] hgfsmounter/Makefile.am: support usrmerge
5
6There is a do_package error when enable usrmerge feature due to the
7hardcoded sbin directory. Remove this piece of code because we already
8create the symbolic link in do_install.
9
10Upstream-Status: Inappropriate [oe-specific]
11
12Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
13---
14 open-vm-tools/hgfsmounter/Makefile.am | 3 ---
15 1 file changed, 3 deletions(-)
16
17diff --git a/open-vm-tools/hgfsmounter/Makefile.am b/open-vm-tools/hgfsmounter/Makefile.am
18index 7c1ba1a..58bd3f8 100644
19--- a/open-vm-tools/hgfsmounter/Makefile.am
20+++ b/open-vm-tools/hgfsmounter/Makefile.am
21@@ -39,9 +39,6 @@ uninstall-hook:
22 rm -f $(DESTDIR)$(sbindir)/mount_vmhgfs
23 else
24 install-exec-hook:
25- -$(MKDIR_P) $(DESTDIR)/sbin
26- -$(LN_S) $(DESTDIR)$(sbindir)/mount.vmhgfs \
27- $(DESTDIR)/sbin/mount.vmhgfs &> /dev/null
28 uninstall-hook:
29 rm -f $(DESTDIR)/sbin/mount.vmhgfs
30 endif !FREEBSD
31--
322.7.4
33
diff --git a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_11.0.1.bb b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_11.0.1.bb
index eda77c2060..34a81d21f0 100644
--- a/meta-oe/recipes-support/open-vm-tools/open-vm-tools_11.0.1.bb
+++ b/meta-oe/recipes-support/open-vm-tools/open-vm-tools_11.0.1.bb
@@ -42,6 +42,7 @@ SRC_URI = "git://github.com/vmware/open-vm-tools.git;protocol=https \
42 file://0001-Make-HgfsConvertFromNtTimeNsec-aware-of-64-bit-time_.patch;patchdir=.. \ 42 file://0001-Make-HgfsConvertFromNtTimeNsec-aware-of-64-bit-time_.patch;patchdir=.. \
43 file://0002-hgfsServerLinux-Consider-64bit-time_t-possibility.patch;patchdir=.. \ 43 file://0002-hgfsServerLinux-Consider-64bit-time_t-possibility.patch;patchdir=.. \
44 file://0001-utilBacktrace-Ignore-Warray-bounds.patch;patchdir=.. \ 44 file://0001-utilBacktrace-Ignore-Warray-bounds.patch;patchdir=.. \
45 file://0001-hgfsmounter-Makefile.am-support-usrmerge.patch;patchdir=.. \
45" 46"
46 47
47SRCREV = "d3edfd142a81096f9f58aff17d84219b457f4987" 48SRCREV = "d3edfd142a81096f9f58aff17d84219b457f4987"
@@ -60,7 +61,8 @@ SYSTEMD_SERVICE_${PN} = "vmtoolsd.service"
60EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs \ 61EXTRA_OECONF = "--without-icu --disable-multimon --disable-docs \
61 --disable-tests --without-gtkmm --without-xerces --without-pam \ 62 --disable-tests --without-gtkmm --without-xerces --without-pam \
62 --disable-vgauth --disable-deploypkg \ 63 --disable-vgauth --disable-deploypkg \
63 --without-root-privileges --without-kernel-modules --with-tirpc" 64 --without-root-privileges --without-kernel-modules --with-tirpc \
65 --with-udev-rules-dir=${nonarch_base_libdir}/udev/rules.d"
64 66
65NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3" 67NO_X11_FLAGS = "--without-x --without-gtk2 --without-gtk3"
66X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf" 68X11_DEPENDS = "libxext libxi libxrender libxrandr libxtst gtk+ gdk-pixbuf"
@@ -83,7 +85,10 @@ CONFFILES_${PN} += "${sysconfdir}/vmware-tools/tools.conf"
83RDEPENDS_${PN} = "util-linux libdnet fuse" 85RDEPENDS_${PN} = "util-linux libdnet fuse"
84 86
85do_install_append() { 87do_install_append() {
86 ln -sf ${sbindir}/mount.vmhgfs ${D}/sbin/mount.vmhgfs 88 if ! ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
89 install -d ${D}/sbin
90 ln -sf ${sbindir}/mount.vmhgfs ${D}/sbin/mount.vmhgfs
91 fi
87 install -d ${D}${sysconfdir}/vmware-tools 92 install -d ${D}${sysconfdir}/vmware-tools
88 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 93 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
89 install -d ${D}${systemd_unitdir}/system 94 install -d ${D}${systemd_unitdir}/system