diff options
Diffstat (limited to 'meta-filesystems/recipes-utils/xfsprogs/files/0001-build-Check-for-sync_file_range-libc-function.patch')
-rw-r--r-- | meta-filesystems/recipes-utils/xfsprogs/files/0001-build-Check-for-sync_file_range-libc-function.patch | 29 |
1 files changed, 13 insertions, 16 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/files/0001-build-Check-for-sync_file_range-libc-function.patch b/meta-filesystems/recipes-utils/xfsprogs/files/0001-build-Check-for-sync_file_range-libc-function.patch index d8ff555319..231da806c4 100644 --- a/meta-filesystems/recipes-utils/xfsprogs/files/0001-build-Check-for-sync_file_range-libc-function.patch +++ b/meta-filesystems/recipes-utils/xfsprogs/files/0001-build-Check-for-sync_file_range-libc-function.patch | |||
@@ -1,14 +1,14 @@ | |||
1 | From ae7172194d3fbb563ff8bbe7c02d34f1bd0e5ec9 Mon Sep 17 00:00:00 2001 | 1 | From f8a22f16c03e51d3c779b12f37d362faaa0ecf31 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Wed, 31 Jan 2018 21:28:53 -0800 | 3 | Date: Wed, 31 Jan 2018 21:28:53 -0800 |
4 | Subject: [PATCH] build: Check for sync_file_range libc function | 4 | Subject: [PATCH] build: Check for sync_file_range libc function |
5 | 5 | ||
6 | glibc 2.27 now has sync_file_range() | 6 | glibc 2.27 now has sync_file_range() |
7 | 7 | ||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | Upstream-Status: Pending | 8 | Upstream-Status: Pending |
11 | 9 | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | include/builddefs.in | 1 + | 12 | include/builddefs.in | 1 + |
13 | io/Makefile | 5 ++++- | 13 | io/Makefile | 5 ++++- |
14 | io/io.h | 2 +- | 14 | io/io.h | 2 +- |
@@ -16,10 +16,10 @@ Upstream-Status: Pending | |||
16 | 4 files changed, 9 insertions(+), 2 deletions(-) | 16 | 4 files changed, 9 insertions(+), 2 deletions(-) |
17 | 17 | ||
18 | diff --git a/include/builddefs.in b/include/builddefs.in | 18 | diff --git a/include/builddefs.in b/include/builddefs.in |
19 | index 92d5076..504225a 100644 | 19 | index b895949..a388c83 100644 |
20 | --- a/include/builddefs.in | 20 | --- a/include/builddefs.in |
21 | +++ b/include/builddefs.in | 21 | +++ b/include/builddefs.in |
22 | @@ -105,6 +105,7 @@ HAVE_FIEMAP = @have_fiemap@ | 22 | @@ -95,6 +95,7 @@ HAVE_FIEMAP = @have_fiemap@ |
23 | HAVE_PREADV = @have_preadv@ | 23 | HAVE_PREADV = @have_preadv@ |
24 | HAVE_PWRITEV2 = @have_pwritev2@ | 24 | HAVE_PWRITEV2 = @have_pwritev2@ |
25 | HAVE_COPY_FILE_RANGE = @have_copy_file_range@ | 25 | HAVE_COPY_FILE_RANGE = @have_copy_file_range@ |
@@ -28,10 +28,10 @@ index 92d5076..504225a 100644 | |||
28 | HAVE_SYNCFS = @have_syncfs@ | 28 | HAVE_SYNCFS = @have_syncfs@ |
29 | HAVE_READDIR = @have_readdir@ | 29 | HAVE_READDIR = @have_readdir@ |
30 | diff --git a/io/Makefile b/io/Makefile | 30 | diff --git a/io/Makefile b/io/Makefile |
31 | index 6725936..1876e95 100644 | 31 | index 00ede48..dd001b0 100644 |
32 | --- a/io/Makefile | 32 | --- a/io/Makefile |
33 | +++ b/io/Makefile | 33 | +++ b/io/Makefile |
34 | @@ -59,10 +59,13 @@ CFILES += inject.c resblks.c | 34 | @@ -60,10 +60,13 @@ CFILES += inject.c resblks.c |
35 | LCFLAGS += -DHAVE_INJECT -DHAVE_RESBLKS | 35 | LCFLAGS += -DHAVE_INJECT -DHAVE_RESBLKS |
36 | endif | 36 | endif |
37 | 37 | ||
@@ -47,10 +47,10 @@ index 6725936..1876e95 100644 | |||
47 | ifeq ($(HAVE_SYNC_FILE_RANGE),yes) | 47 | ifeq ($(HAVE_SYNC_FILE_RANGE),yes) |
48 | CFILES += sync_file_range.c | 48 | CFILES += sync_file_range.c |
49 | diff --git a/io/io.h b/io/io.h | 49 | diff --git a/io/io.h b/io/io.h |
50 | index 3862985..79ddc7b 100644 | 50 | index e1f3d95..fe2e6a2 100644 |
51 | --- a/io/io.h | 51 | --- a/io/io.h |
52 | +++ b/io/io.h | 52 | +++ b/io/io.h |
53 | @@ -158,7 +158,7 @@ extern void fiemap_init(void); | 53 | @@ -151,7 +151,7 @@ extern void fiemap_init(void); |
54 | #define fiemap_init() do { } while (0) | 54 | #define fiemap_init() do { } while (0) |
55 | #endif | 55 | #endif |
56 | 56 | ||
@@ -60,23 +60,20 @@ index 3862985..79ddc7b 100644 | |||
60 | #else | 60 | #else |
61 | #define copy_range_init() do { } while (0) | 61 | #define copy_range_init() do { } while (0) |
62 | diff --git a/io/sync_file_range.c b/io/sync_file_range.c | 62 | diff --git a/io/sync_file_range.c b/io/sync_file_range.c |
63 | index 7e4f3e6..aafea01 100644 | 63 | index 30bbc93..6c49d73 100644 |
64 | --- a/io/sync_file_range.c | 64 | --- a/io/sync_file_range.c |
65 | +++ b/io/sync_file_range.c | 65 | +++ b/io/sync_file_range.c |
66 | @@ -16,6 +16,7 @@ | 66 | @@ -4,6 +4,7 @@ |
67 | * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA | 67 | * All Rights Reserved. |
68 | */ | 68 | */ |
69 | 69 | ||
70 | +#ifndef HAVE_COPY_FILE_RANGE | 70 | +#ifndef HAVE_COPY_FILE_RANGE |
71 | #include "command.h" | 71 | #include "command.h" |
72 | #include "input.h" | 72 | #include "input.h" |
73 | #include "init.h" | 73 | #include "init.h" |
74 | @@ -104,3 +105,5 @@ sync_range_init(void) | 74 | @@ -92,3 +93,5 @@ sync_range_init(void) |
75 | 75 | ||
76 | add_command(&sync_range_cmd); | 76 | add_command(&sync_range_cmd); |
77 | } | 77 | } |
78 | + | 78 | + |
79 | +#endif | 79 | +#endif |
80 | -- | ||
81 | 2.16.1 | ||
82 | |||