summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch')
-rw-r--r--meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch b/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch
new file mode 100644
index 0000000000..dbf0082640
--- /dev/null
+++ b/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch
@@ -0,0 +1,23 @@
1When "make -j10", the compilation will fail,
2because scan.c has included gram.h, but gram.h was produced
3after scan.c was compiled
4
5So add this dependency to ensure that gram.h is produced
6before scan.c is produced.
7
8Upstream-Status: Inappropriate [upstream is not active]
9
10Signed-off-by: Roy.Li <RongQing.Li@windriver.com>
11Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
12---
13 src/Makefile.am | 2 ++
14 1 file changed, 2 insertions(+)
15
16--- a/src/Makefile.am
17+++ b/src/Makefile.am
18@@ -81,3 +81,5 @@ CLEANFILES = gram.c gram.h \
19
20 DISTCLEANFILES = $(BUILT_SOURCES)
21 MAINTAINERCLEANFILES = Makefile.in
22+
23+scan.c: gram.h