diff options
author | Jackie Huang <jackie.huang@windriver.com> | 2017-06-02 16:04:56 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-06-12 06:56:44 +0200 |
commit | b58c258b6e93d4f932faf526a8b32434b1d440e7 (patch) | |
tree | abe67df6c0bba9e1b48d1817876d3f39e1f1eeda /meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch | |
parent | fb26fdcda0b719512fac4760e680b213c0b016c0 (diff) | |
download | meta-openembedded-b58c258b6e93d4f932faf526a8b32434b1d440e7.tar.gz |
umip: fix for parallel compilation
Add missing dependency in Makefile to fix the
parallel compile issue and re-enable PARALLEL_MAKE
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch')
-rw-r--r-- | meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch | 23 |
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch b/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch new file mode 100644 index 0000000000..dbf0082640 --- /dev/null +++ b/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | When "make -j10", the compilation will fail, | ||
2 | because scan.c has included gram.h, but gram.h was produced | ||
3 | after scan.c was compiled | ||
4 | |||
5 | So add this dependency to ensure that gram.h is produced | ||
6 | before scan.c is produced. | ||
7 | |||
8 | Upstream-Status: Inappropriate [upstream is not active] | ||
9 | |||
10 | Signed-off-by: Roy.Li <RongQing.Li@windriver.com> | ||
11 | Signed-off-by: Jackie Huang <jackie.huang@windriver.com> | ||
12 | --- | ||
13 | src/Makefile.am | 2 ++ | ||
14 | 1 file changed, 2 insertions(+) | ||
15 | |||
16 | --- a/src/Makefile.am | ||
17 | +++ b/src/Makefile.am | ||
18 | @@ -81,3 +81,5 @@ CLEANFILES = gram.c gram.h \ | ||
19 | |||
20 | DISTCLEANFILES = $(BUILT_SOURCES) | ||
21 | MAINTAINERCLEANFILES = Makefile.in | ||
22 | + | ||
23 | +scan.c: gram.h | ||