diff options
Diffstat (limited to 'meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-outside-tests.patch')
-rw-r--r-- | meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-outside-tests.patch | 142 |
1 files changed, 142 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-outside-tests.patch b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-outside-tests.patch new file mode 100644 index 0000000000..b9b3591c3a --- /dev/null +++ b/meta-oe/recipes-support/cpprest/cpprest-2.10.3/disable-outside-tests.patch | |||
@@ -0,0 +1,142 @@ | |||
1 | Description: Debian forbids calls to external websites. | ||
2 | |||
3 | Author: Gianfranco Costamagna <costamagnagianfranco@yahoo.it> | ||
4 | Origin: Debian | ||
5 | Forwarded: not-needed | ||
6 | Reviewed-By: Gianfranco Costamagna <costamagnagianfranco@yahoo.it> | ||
7 | Last-Update: 2015-11-25 | ||
8 | |||
9 | Index: casablanca/Release/tests/functional/http/client/CMakeLists.txt | ||
10 | =================================================================== | ||
11 | --- casablanca.orig/Release/tests/functional/http/client/CMakeLists.txt | ||
12 | +++ casablanca/Release/tests/functional/http/client/CMakeLists.txt | ||
13 | @@ -9,7 +9,6 @@ | ||
14 | multiple_requests.cpp | ||
15 | oauth1_tests.cpp | ||
16 | oauth2_tests.cpp | ||
17 | - outside_tests.cpp | ||
18 | pipeline_stage_tests.cpp | ||
19 | progress_handler_tests.cpp | ||
20 | proxy_tests.cpp | ||
21 | Index: casablanca/Release/tests/functional/http/client/authentication_tests.cpp | ||
22 | =================================================================== | ||
23 | --- casablanca.orig/Release/tests/functional/http/client/authentication_tests.cpp | ||
24 | +++ casablanca/Release/tests/functional/http/client/authentication_tests.cpp | ||
25 | @@ -663,15 +663,19 @@ | ||
26 | VERIFY_ARE_EQUAL(return_code, response.status_code()); | ||
27 | } | ||
28 | |||
29 | +/* | ||
30 | TEST(auth_no_data) | ||
31 | { | ||
32 | auth_test_impl(false); | ||
33 | } | ||
34 | +*/ | ||
35 | |||
36 | +/* | ||
37 | TEST(unsuccessful_auth_with_basic_cred) | ||
38 | { | ||
39 | auth_test_impl(true); | ||
40 | } | ||
41 | +*/ | ||
42 | |||
43 | TEST_FIXTURE(uri_address, set_user_options_asio_http) | ||
44 | { | ||
45 | @@ -692,7 +696,7 @@ | ||
46 | auto response = client.request(methods::GET).get(); | ||
47 | VERIFY_ARE_EQUAL(200, response.status_code()); | ||
48 | } | ||
49 | - | ||
50 | +/* | ||
51 | TEST_FIXTURE(uri_address, set_user_options_asio_https) | ||
52 | { | ||
53 | handle_timeout([] | ||
54 | @@ -714,7 +718,7 @@ | ||
55 | VERIFY_IS_FALSE(v.empty()); | ||
56 | }); | ||
57 | } | ||
58 | - | ||
59 | +*/ | ||
60 | #endif | ||
61 | |||
62 | } // SUITE(authentication_tests) | ||
63 | Index: casablanca/Release/tests/functional/websockets/client/authentication_tests.cpp | ||
64 | =================================================================== | ||
65 | --- casablanca.orig/Release/tests/functional/websockets/client/authentication_tests.cpp | ||
66 | +++ casablanca/Release/tests/functional/websockets/client/authentication_tests.cpp | ||
67 | @@ -86,7 +86,7 @@ | ||
68 | } | ||
69 | return false; | ||
70 | } | ||
71 | - | ||
72 | +/* | ||
73 | TEST(ssl_test) | ||
74 | { | ||
75 | websocket_client client; | ||
76 | @@ -122,7 +122,7 @@ | ||
77 | throw; | ||
78 | } | ||
79 | } | ||
80 | - | ||
81 | +*/ | ||
82 | // These tests are specific to our websocketpp based implementation. | ||
83 | #if !defined(__cplusplus_winrt) | ||
84 | |||
85 | @@ -153,14 +153,15 @@ | ||
86 | throw; | ||
87 | } | ||
88 | } | ||
89 | - | ||
90 | +/* | ||
91 | // Test specifically for server SignalR team hit interesting cases with. | ||
92 | TEST(sni_with_older_server_test) | ||
93 | { | ||
94 | websocket_client client; | ||
95 | sni_test_impl(client); | ||
96 | } | ||
97 | - | ||
98 | +*/ | ||
99 | +/* | ||
100 | // WinRT doesn't expose option for disabling. | ||
101 | // No stable server is available to reliably test this. | ||
102 | // The configuration below relies on a timeout in the success case. | ||
103 | @@ -188,7 +189,8 @@ | ||
104 | throw; | ||
105 | } | ||
106 | } | ||
107 | - | ||
108 | +*/ | ||
109 | +/* | ||
110 | // Winrt doesn't allow explicitly setting server host for SNI. | ||
111 | TEST(sni_explicit_hostname) | ||
112 | { | ||
113 | @@ -199,7 +201,7 @@ | ||
114 | websocket_client client(config); | ||
115 | sni_test_impl(client); | ||
116 | } | ||
117 | - | ||
118 | +*/ | ||
119 | void handshake_error_test_impl(const ::utility::string_t &host) | ||
120 | { | ||
121 | websocket_client client; | ||
122 | Index: casablanca/Release/tests/functional/http/client/connections_and_errors.cpp | ||
123 | =================================================================== | ||
124 | --- casablanca.orig/Release/tests/functional/http/client/connections_and_errors.cpp | ||
125 | +++ casablanca/Release/tests/functional/http/client/connections_and_errors.cpp | ||
126 | @@ -415,6 +415,7 @@ | ||
127 | } | ||
128 | #endif | ||
129 | |||
130 | +/* | ||
131 | // Try to connect to a server on a closed port and cancel the operation. | ||
132 | TEST_FIXTURE(uri_address, cancel_bad_port) | ||
133 | { | ||
134 | @@ -446,7 +447,7 @@ | ||
135 | |||
136 | VERIFY_THROWS_HTTP_ERROR_CODE(t.get(), std::errc::operation_canceled); | ||
137 | } | ||
138 | - | ||
139 | +*/ | ||
140 | } // SUITE(connections_and_errors) | ||
141 | |||
142 | }}}} | ||