summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch')
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch138
1 files changed, 138 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch b/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
new file mode 100644
index 0000000000..5232e2a1d8
--- /dev/null
+++ b/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
@@ -0,0 +1,138 @@
1Description: Debian forbids calls to external websites.
2
3Author: Gianfranco Costamagna <locutus@debian.org>
4Origin: Debian
5Forwarded: not-needed
6Reviewed-By: Gianfranco Costamagna <locutusofborg@debian.org>
7Last-Update: 2015-11-25
8
9Index: cpprest/Release/tests/functional/http/client/CMakeLists.txt
10===================================================================
11--- cpprest.orig/Release/tests/functional/http/client/CMakeLists.txt
12+++ cpprest/Release/tests/functional/http/client/CMakeLists.txt
13@@ -12,7 +12,6 @@
14 multiple_requests.cpp
15 oauth1_tests.cpp
16 oauth2_tests.cpp
17- outside_tests.cpp
18 pipeline_stage_tests.cpp
19 progress_handler_tests.cpp
20 proxy_tests.cpp
21Index: cpprest/Release/tests/functional/http/client/authentication_tests.cpp
22===================================================================
23--- cpprest.orig/Release/tests/functional/http/client/authentication_tests.cpp
24+++ cpprest/Release/tests/functional/http/client/authentication_tests.cpp
25@@ -675,9 +675,9 @@
26 VERIFY_ARE_EQUAL(return_code, response.status_code());
27 }
28
29- TEST(auth_no_data) { auth_test_impl(false); }
30+ //TEST(auth_no_data) { auth_test_impl(false); }
31
32- TEST(unsuccessful_auth_with_basic_cred) { auth_test_impl(true); }
33+ //TEST(unsuccessful_auth_with_basic_cred) { auth_test_impl(true); }
34
35 TEST_FIXTURE(uri_address, set_user_options_asio_http)
36 {
37@@ -695,6 +695,7 @@
38 VERIFY_ARE_EQUAL(200, response.status_code());
39 }
40
41+ /*
42 TEST_FIXTURE(uri_address, set_user_options_asio_https)
43 {
44 handle_timeout([] {
45@@ -714,6 +715,7 @@
46 VERIFY_IS_FALSE(v.empty());
47 });
48 }
49+ */
50
51 #endif
52
53Index: cpprest/Release/tests/functional/websockets/client/authentication_tests.cpp
54===================================================================
55--- cpprest.orig/Release/tests/functional/websockets/client/authentication_tests.cpp
56+++ cpprest/Release/tests/functional/websockets/client/authentication_tests.cpp
57@@ -93,6 +93,7 @@
58 return false;
59 }
60
61+ /*
62 TEST(ssl_test)
63 {
64 websocket_client client;
65@@ -127,6 +128,7 @@
66 throw;
67 }
68 }
69+ */
70
71 // These tests are specific to our websocketpp based implementation.
72 #if !defined(__cplusplus_winrt)
73@@ -159,12 +161,14 @@
74 }
75 }
76
77+ /*
78 // Test specifically for server SignalR team hit interesting cases with.
79 TEST(sni_with_older_server_test)
80 {
81 websocket_client client;
82 sni_test_impl(client);
83 }
84+ */
85
86 // WinRT doesn't expose option for disabling.
87 // No stable server is available to reliably test this.
88@@ -194,6 +198,7 @@
89 }
90 }
91
92+ /*
93 // Winrt doesn't allow explicitly setting server host for SNI.
94 TEST(sni_explicit_hostname)
95 {
96@@ -204,6 +209,7 @@
97 websocket_client client(config);
98 sni_test_impl(client);
99 }
100+ */
101
102 void handshake_error_test_impl(const ::utility::string_t& host)
103 {
104@@ -225,11 +231,11 @@
105 }
106 }
107
108- TEST(self_signed_cert) { handshake_error_test_impl(U("wss://self-signed.badssl.com/")); }
109+ //TEST(self_signed_cert) { handshake_error_test_impl(U("wss://self-signed.badssl.com/")); }
110
111- TEST(hostname_mismatch) { handshake_error_test_impl(U("wss://wrong.host.badssl.com/")); }
112+ //TEST(hostname_mismatch) { handshake_error_test_impl(U("wss://wrong.host.badssl.com/")); }
113
114- TEST(cert_expired) { handshake_error_test_impl(U("wss://expired.badssl.com/")); }
115+ //TEST(cert_expired) { handshake_error_test_impl(U("wss://expired.badssl.com/")); }
116
117 #endif
118
119Index: cpprest/Release/tests/functional/http/client/connections_and_errors.cpp
120===================================================================
121--- cpprest.orig/Release/tests/functional/http/client/connections_and_errors.cpp
122+++ cpprest/Release/tests/functional/http/client/connections_and_errors.cpp
123@@ -406,6 +406,7 @@
124 }
125 #endif
126
127+ /*
128 // Try to connect to a server on a closed port and cancel the operation.
129 TEST_FIXTURE(uri_address, cancel_bad_port)
130 {
131@@ -437,6 +438,7 @@
132
133 VERIFY_THROWS_HTTP_ERROR_CODE(t.get(), std::errc::operation_canceled);
134 }
135+ */
136
137 } // SUITE(connections_and_errors)
138