diff options
Diffstat (limited to 'meta-oe/recipes-support/satyr/files/0001-do-not-support-python2.patch')
-rw-r--r-- | meta-oe/recipes-support/satyr/files/0001-do-not-support-python2.patch | 84 |
1 files changed, 0 insertions, 84 deletions
diff --git a/meta-oe/recipes-support/satyr/files/0001-do-not-support-python2.patch b/meta-oe/recipes-support/satyr/files/0001-do-not-support-python2.patch deleted file mode 100644 index 9e95a3f9d1..0000000000 --- a/meta-oe/recipes-support/satyr/files/0001-do-not-support-python2.patch +++ /dev/null | |||
@@ -1,84 +0,0 @@ | |||
1 | From 206f334d62da17093e784094c9d9e80c853f704f Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Fri, 12 May 2017 03:03:46 -0400 | ||
4 | Subject: [PATCH] do not support python2 | ||
5 | |||
6 | Upstream-Status: Inappropriate [oe specific] | ||
7 | |||
8 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
9 | --- | ||
10 | configure.ac | 16 ---------------- | ||
11 | python/Makefile.am | 24 ------------------------ | ||
12 | 2 files changed, 40 deletions(-) | ||
13 | |||
14 | diff --git a/configure.ac b/configure.ac | ||
15 | index 200a7cc..8431c51 100644 | ||
16 | --- a/configure.ac | ||
17 | +++ b/configure.ac | ||
18 | @@ -22,22 +22,6 @@ AM_MISSING_PROG([AUTOM4TE], [autom4te]) | ||
19 | # Needed by tests/atlocal.in. | ||
20 | AC_SUBST([O0CFLAGS], [`echo $CFLAGS | sed 's/-O[[0-9]] *//'`]) | ||
21 | |||
22 | -AM_PATH_PYTHON | ||
23 | -AM_CONDITIONAL([HAVE_PYTHON], test -n "$PYTHON") | ||
24 | -[if test -z "$PYTHON"; then] | ||
25 | - [echo "The python interpreter was not found in the search path. The Python language bindings"] | ||
26 | - [echo "will not be built. If you want to build the Python language bindings, please ensure"] | ||
27 | - [echo "that python is installed and its directory is included in the search path."] | ||
28 | - [echo "Then run configure again before attempting to build Satyr."] | ||
29 | -[fi] | ||
30 | - | ||
31 | -# Just PKG_CHECK_MODULES([PYTHON], [python]) works only with python2.7+ | ||
32 | -# Below, if python is not found, we set up for python2.6 w/o checking: | ||
33 | -PKG_CHECK_MODULES([PYTHON], [python2],,[ | ||
34 | - PYTHON_LIBS='-L/usr/lib64 -lpython2.6' | ||
35 | - PYTHON_CFLAGS='-I/usr/include/python2.6' | ||
36 | -]) | ||
37 | - | ||
38 | AC_ARG_ENABLE([python-manpage], | ||
39 | [AS_HELP_STRING([--disable-python-manpage], | ||
40 | [Disable python bindings manpage build])], | ||
41 | diff --git a/python/Makefile.am b/python/Makefile.am | ||
42 | index 36fc2e9..0b73f66 100644 | ||
43 | --- a/python/Makefile.am | ||
44 | +++ b/python/Makefile.am | ||
45 | @@ -1,12 +1,5 @@ | ||
46 | SUBDIRS = . doc | ||
47 | |||
48 | -py2satyrdir = $(pyexecdir)/satyr | ||
49 | - | ||
50 | -py2satyr_PYTHON = \ | ||
51 | - __init__.py | ||
52 | - | ||
53 | -py2satyr_LTLIBRARIES = _satyr.la | ||
54 | - | ||
55 | PYEXTFILES = \ | ||
56 | py_cluster.h \ | ||
57 | py_cluster.c \ | ||
58 | @@ -75,23 +68,6 @@ PYEXTLDFLAGS = \ | ||
59 | -module \ | ||
60 | -avoid-version | ||
61 | |||
62 | -_satyr_la_SOURCES = $(PYEXTFILES) | ||
63 | -_satyr_la_CPPFLAGS = \ | ||
64 | - $(PYEXTCPPFLAGS) \ | ||
65 | - $(PYTHON_CFLAGS) | ||
66 | -_satyr_la_LDFLAGS = \ | ||
67 | - $(PYEXTLDFLAGS) \ | ||
68 | - -export-symbols-regex init_satyr | ||
69 | - | ||
70 | -# Depending on the configure option, we either link libsatyr.so dynamically (as | ||
71 | -# is usual), or directly include its object files (by including the | ||
72 | -# convenience library). | ||
73 | -if ENABLE_STATIC_PYTHON_MODULE | ||
74 | -_satyr_la_LIBADD = ../lib/libsatyr_conv.la | ||
75 | -else | ||
76 | -_satyr_la_LIBADD = ../lib/libsatyr.la | ||
77 | -endif | ||
78 | - | ||
79 | if WITH_PYTHON3 | ||
80 | py3satyrdir = $(py3execdir)/satyr | ||
81 | |||
82 | -- | ||
83 | 2.8.1 | ||
84 | |||