summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0131.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0131.bb')
-rw-r--r--meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0131.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0131.bb b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0131.bb
new file mode 100644
index 0000000000..4105249538
--- /dev/null
+++ b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0131.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Perl interface to the libxml2 library"
2DESCRIPTION = "This module is an interface to libxml2, providing XML and HTML parsers \
3with DOM, SAX and XMLReader interfaces, a large subset of DOM Layer 3 \
4interface and a XML::XPath-like interface to XPath API of libxml2. \
5The module is split into several packages which are not described in this \
6section; unless stated otherwise, you only need to use XML::LibXML; in \
7your programs."
8
9HOMEPAGE = "http://search.cpan.org/dist/XML-LibXML-1.99/"
10SECTION = "libs"
11LICENSE = "Artistic-1.0|GPLv1+"
12DEPENDS += "libxml2 \
13 libxml-sax-perl-native \
14 zlib \
15"
16RDEPENDS_${PN} += "libxml2 \
17 libxml-sax-perl \
18 libxml-sax-base-perl \
19 zlib \
20"
21
22SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/XML-LibXML-${PV}.tar.gz;name=libxml \
23 file://disable-libxml2-check.patch \
24 file://fix-CATALOG-conditional-compile.patch \
25 file://using-DOCB-conditional.patch \
26"
27LIC_FILES_CHKSUM = "file://debian/copyright;md5=64eda1bc135f0ece1d1187f2a8ac82c1 \
28 file://LICENSE;md5=97871bde150daeb5e61ad95137ff2446 \
29"
30SRC_URI[libxml.md5sum] = "4dd1efcda5159c9e73139a4546190665"
31SRC_URI[libxml.sha256sum] = "b04c77dea55f9f270e1040e3a1d4f79b81dcdcd4da3e648f92dcf6c80bbe19df"
32
33S = "${WORKDIR}/XML-LibXML-${PV}"
34
35inherit cpan
36
37EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}"
38
39BBCLASSEXTEND = "native"
40
41CFLAGS += " -D_GNU_SOURCE "
42BUILD_CFLAGS += " -D_GNU_SOURCE "
43
44FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/XML/LibXML/.debug/"