diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch | 50 |
1 files changed, 0 insertions, 50 deletions
diff --git a/meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch b/meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch deleted file mode 100644 index c29b659bc3..0000000000 --- a/meta-python/recipes-devtools/python/python-automat/0001-setup.py-remove-the-dependency-on-m2r.patch +++ /dev/null | |||
@@ -1,50 +0,0 @@ | |||
1 | From 33b70266930c9093712173c4e0c419815b55e313 Mon Sep 17 00:00:00 2001 | ||
2 | From: Derek Straka <derek@asterius.io> | ||
3 | Date: Fri, 22 Dec 2017 09:07:00 -0500 | ||
4 | Subject: [PATCH] setup.py: remove the dependency on m2r | ||
5 | |||
6 | The dependency on m2r is removed here as it only provides the | ||
7 | long_description value that is optional. This item is just the | ||
8 | text that would be present on PyPi, so it doesn't provide much | ||
9 | value in this case | ||
10 | |||
11 | Upstream-Status: Inappropriate (OE specific) | ||
12 | |||
13 | Signed-off-by: Derek Straka <derek@asterius.io> | ||
14 | |||
15 | --- | ||
16 | setup.py | 10 ---------- | ||
17 | 1 file changed, 10 deletions(-) | ||
18 | |||
19 | diff --git a/setup.py b/setup.py | ||
20 | index d360c64..7b4180a 100644 | ||
21 | --- a/setup.py | ||
22 | +++ b/setup.py | ||
23 | @@ -4,14 +4,6 @@ Setup file for automat | ||
24 | |||
25 | from setuptools import setup, find_packages | ||
26 | |||
27 | -try: | ||
28 | - from m2r import parse_from_file | ||
29 | - long_description = parse_from_file('README.md') | ||
30 | -except(IOError, ImportError): | ||
31 | - print("\n\n!!! m2r not found, long_description is bad, don't upload this to PyPI !!!\n\n") | ||
32 | - import io | ||
33 | - long_description = io.open('README.md', encoding="utf-8").read() | ||
34 | - | ||
35 | setup( | ||
36 | name='Automat', | ||
37 | use_scm_version=True, | ||
38 | @@ -19,12 +11,10 @@ setup( | ||
39 | description=""" | ||
40 | Self-service finite-state machines for the programmer on the go. | ||
41 | """.strip(), | ||
42 | - long_description=long_description, | ||
43 | packages=find_packages(exclude=[]), | ||
44 | package_dir={'automat': 'automat'}, | ||
45 | setup_requires=[ | ||
46 | 'setuptools-scm', | ||
47 | - 'm2r', | ||
48 | ], | ||
49 | install_requires=[ | ||
50 | "attrs>=16.1.0", | ||