diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio')
4 files changed, 0 insertions, 99 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch deleted file mode 100644 index f17f048de8..0000000000 --- a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | From b02be74a2eff8abc612ef84f30e0fbce6a7f65f5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 4 Aug 2017 09:04:07 -0700 | ||
4 | Subject: [PATCH] setup.py: Do not mix C and C++ compiler options | ||
5 | |||
6 | EXTRA_ENV_COMPILE_ARGS is used both with CC and CXX | ||
7 | so using -std=c++11 or -std=gnu99 together will cause | ||
8 | build time errors espcially with clang | ||
9 | |||
10 | error: invalid argument '-std=gnu99' not allowed with 'C++' | ||
11 | |||
12 | gcc7 ( defaults are -std=gnu11 and -std=gnu++14 ) | ||
13 | as well clang default to these standards mode or newer | ||
14 | anyway | ||
15 | |||
16 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
17 | --- | ||
18 | setup.py | 2 +- | ||
19 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
20 | |||
21 | --- a/setup.py | ||
22 | +++ b/setup.py | ||
23 | @@ -145,7 +145,7 @@ ENABLE_DOCUMENTATION_BUILD = os.environ. | ||
24 | EXTRA_ENV_COMPILE_ARGS = os.environ.get('GRPC_PYTHON_CFLAGS', None) | ||
25 | EXTRA_ENV_LINK_ARGS = os.environ.get('GRPC_PYTHON_LDFLAGS', None) | ||
26 | if EXTRA_ENV_COMPILE_ARGS is None: | ||
27 | - EXTRA_ENV_COMPILE_ARGS = ' -std=c++11' | ||
28 | + EXTRA_ENV_COMPILE_ARGS = "" | ||
29 | if 'win32' in sys.platform and sys.version_info < (3, 5): | ||
30 | EXTRA_ENV_COMPILE_ARGS += ' -D_hypot=hypot' | ||
31 | # We use define flags here and don't directly add to DEFINE_MACROS below to | ||
32 | @@ -157,7 +157,7 @@ if EXTRA_ENV_COMPILE_ARGS is None: | ||
33 | else: | ||
34 | EXTRA_ENV_COMPILE_ARGS += ' -D_ftime=_ftime64 -D_timeb=__timeb64' | ||
35 | elif "linux" in sys.platform: | ||
36 | - EXTRA_ENV_COMPILE_ARGS += ' -std=gnu99 -fvisibility=hidden -fno-wrapv -fno-exceptions' | ||
37 | + EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions' | ||
38 | elif "darwin" in sys.platform: | ||
39 | EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions' | ||
40 | EXTRA_ENV_COMPILE_ARGS += ' -DPB_FIELD_32BIT' | ||
diff --git a/meta-python/recipes-devtools/python/python-grpcio/gettid.patch b/meta-python/recipes-devtools/python/python-grpcio/gettid.patch deleted file mode 100644 index fb15cf7f96..0000000000 --- a/meta-python/recipes-devtools/python/python-grpcio/gettid.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | use glibc provided gettid API for glibc 2.30+ | ||
2 | |||
3 | glibc 2.30 introduced this function see [1] | ||
4 | so it's best to detect it | ||
5 | and provide fallback only if it's not present | ||
6 | |||
7 | [1] https://sourceware.org/bugzilla/show_bug.cgi?id=6399 | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- a/src/core/lib/gpr/log_linux.cc | ||
12 | +++ b/src/core/lib/gpr/log_linux.cc | ||
13 | @@ -40,7 +40,13 @@ | ||
14 | #include <time.h> | ||
15 | #include <unistd.h> | ||
16 | |||
17 | +#if defined(__GLIBC__) | ||
18 | +#if !__GLIBC_PREREQ(2,29) | ||
19 | static long gettid(void) { return syscall(__NR_gettid); } | ||
20 | +#endif | ||
21 | +#else | ||
22 | +static long gettid(void) { return syscall(__NR_gettid); } | ||
23 | +#endif | ||
24 | |||
25 | void gpr_log(const char* file, int line, gpr_log_severity severity, | ||
26 | const char* format, ...) { | ||
diff --git a/meta-python/recipes-devtools/python/python-grpcio/ppc-boringssl-support.patch b/meta-python/recipes-devtools/python/python-grpcio/ppc-boringssl-support.patch deleted file mode 100644 index 6435abbe6d..0000000000 --- a/meta-python/recipes-devtools/python/python-grpcio/ppc-boringssl-support.patch +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | Let boringSSL compile on ppc32 bit | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
5 | |||
6 | --- a/third_party/boringssl/include/openssl/base.h | ||
7 | +++ b/third_party/boringssl/include/openssl/base.h | ||
8 | @@ -95,6 +95,9 @@ extern "C" { | ||
9 | #elif (defined(__PPC64__) || defined(__powerpc64__)) && defined(_LITTLE_ENDIAN) | ||
10 | #define OPENSSL_64_BIT | ||
11 | #define OPENSSL_PPC64LE | ||
12 | +#elif (defined(__PPC__) || defined(__powerpc__)) | ||
13 | +#define OPENSSL_32_BIT | ||
14 | +#define OPENSSL_PPC | ||
15 | #elif defined(__mips__) && !defined(__LP64__) | ||
16 | #define OPENSSL_32_BIT | ||
17 | #define OPENSSL_MIPS | ||
diff --git a/meta-python/recipes-devtools/python/python-grpcio/riscv64_support.patch b/meta-python/recipes-devtools/python/python-grpcio/riscv64_support.patch deleted file mode 100644 index fef7d9e757..0000000000 --- a/meta-python/recipes-devtools/python/python-grpcio/riscv64_support.patch +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | Add RISC-V 64bit support | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
5 | --- a/third_party/boringssl/include/openssl/base.h | ||
6 | +++ b/third_party/boringssl/include/openssl/base.h | ||
7 | @@ -104,6 +104,9 @@ extern "C" { | ||
8 | #elif defined(__mips__) && defined(__LP64__) | ||
9 | #define OPENSSL_64_BIT | ||
10 | #define OPENSSL_MIPS64 | ||
11 | +#elif defined(__riscv) && defined(__riscv_xlen) | ||
12 | +#define OPENSSL_64_BIT | ||
13 | +#define OPENSSL_RISCV64 | ||
14 | #elif defined(__pnacl__) | ||
15 | #define OPENSSL_32_BIT | ||
16 | #define OPENSSL_PNACL | ||