summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-grpcio
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
index 3686144b38..3abbc6d6f1 100644
--- a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
+++ b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -26,8 +26,8 @@ index cb85273..f79878d 100644
26 elif 'win32' in sys.platform: 26 elif 'win32' in sys.platform:
27 EXTRA_ENV_COMPILE_ARGS += ' -D_PYTHON_MSVC' 27 EXTRA_ENV_COMPILE_ARGS += ' -D_PYTHON_MSVC'
28 elif "linux" in sys.platform: 28 elif "linux" in sys.platform:
29- EXTRA_ENV_COMPILE_ARGS += ' -std=c++11 -std=gnu99 -fvisibility=hidden -fno-wrapv' 29- EXTRA_ENV_COMPILE_ARGS += ' -std=c++11 -std=gnu99 -fvisibility=hidden -fno-wrapv -fno-exceptions'
30+ EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv' 30+ EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions'
31 elif "darwin" in sys.platform: 31 elif "darwin" in sys.platform:
32 EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv' 32 EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv'
33 33