diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch | 25 |
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch b/meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch new file mode 100644 index 0000000000..028a51ad59 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | Avoid getting host sysroot paths in the library paths to fix issue like: | ||
2 | |||
3 | | /home/andrei/work/yocto/build-rpi-master/tmp/sysroots/x86_64-linux/usr/lib/libz.so: file not recognized: File format not recognized | ||
4 | |||
5 | Upstream-Status: Inappropriate [configuration] | ||
6 | |||
7 | Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> | ||
8 | |||
9 | |||
10 | Index: Imaging-1.1.7/setup.py | ||
11 | =================================================================== | ||
12 | --- Imaging-1.1.7.orig/setup.py | ||
13 | +++ Imaging-1.1.7/setup.py | ||
14 | @@ -155,11 +155,6 @@ class pil_build_ext(build_ext): | ||
15 | |||
16 | # FIXME: check /opt/stuff directories here? | ||
17 | |||
18 | - prefix = sysconfig.get_config_var("prefix") | ||
19 | - if prefix: | ||
20 | - add_directory(library_dirs, os.path.join(prefix, "lib")) | ||
21 | - add_directory(include_dirs, os.path.join(prefix, "include")) | ||
22 | - | ||
23 | # | ||
24 | # locate tkinter libraries | ||
25 | |||