summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch21
1 files changed, 12 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch b/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch
index c6654e5402..4b64f4613c 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch
+++ b/meta-python/recipes-devtools/python/python-m2crypto/cross-compile-platform.patch
@@ -4,27 +4,30 @@ since it pokes at the system for getting architecture values
4Upstream-Status: Inappropriate 4Upstream-Status: Inappropriate
5Signed-off-by: Khem Raj <raj.khem@gmail.com> 5Signed-off-by: Khem Raj <raj.khem@gmail.com>
6 6
7Index: M2Crypto-0.26.0/setup.py 7Index: M2Crypto-0.30.1/setup.py
8=================================================================== 8===================================================================
9--- M2Crypto-0.26.0.orig/setup.py 9--- M2Crypto-0.30.1.orig/setup.py
10+++ M2Crypto-0.26.0/setup.py 10+++ M2Crypto-0.30.1/setup.py
11@@ -141,19 +141,6 @@ class _M2CryptoBuildExt(build_ext.build_ 11@@ -160,22 +160,6 @@ class _M2CryptoBuildExt(build_ext.build_
12 self.include_dirs.append( 12 log.debug('self.include_dirs = %s', self.include_dirs)
13 os.path.join(self.openssl, 'include', 'openssl')) 13 log.debug('self.library_dirs = %s', self.library_dirs)
14 14
15- if platform.system() == "Linux":
15- # For RedHat-based distros, the '-D__{arch}__' option for 16- # For RedHat-based distros, the '-D__{arch}__' option for
16- # Swig needs to be normalized, particularly on i386. 17- # Swig needs to be normalized, particularly on i386.
17- mach = platform.machine().lower() 18- mach = platform.machine().lower()
18- if mach in ('i386', 'i486', 'i586', 'i686'): 19- if mach in ('i386', 'i486', 'i586', 'i686'):
19- arch = '__i386__' 20- arch = '__i386__'
20- elif mach in ('ppc64', 'powerpc64'): 21- elif mach in ('ppc64', 'powerpc64', 'ppc64le', 'ppc64el'):
21- arch = '__powerpc64__' 22- arch = '__powerpc64__'
22- elif mach in ('ppc', 'powerpc'): 23- elif mach in ('ppc', 'powerpc'):
23- arch = '__powerpc__' 24- arch = '__powerpc__'
24- else: 25- else:
25- arch = '__%s__' % mach 26- arch = '__%s__' % mach
26- self.swig_opts.append('-D%s' % arch) 27- self.swig_opts.append('-D%s' % arch)
28- if mach in ('ppc64le', 'ppc64el'):
29- self.swig_opts.append('-D_CALL_ELF=2')
27- 30-
28 self.swig_opts.extend(['-I%s' % i for i in self.include_dirs]) 31 self.swig_opts.extend(['-I%s' % i for i in self.include_dirs])
29 self.swig_opts.append('-includeall') 32
30 self.swig_opts.append('-modern') 33 # Some Linux distributor has added the following line in