summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch
new file mode 100644
index 0000000000..b3180f29f2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch
@@ -0,0 +1,30 @@
1From a681a79472df85cdc8c052bc61fb8b9e7b9a6495 Mon Sep 17 00:00:00 2001
2From: Tim Orling <tim.orling@konsulko.com>
3Date: Sun, 27 Feb 2022 11:50:36 -0800
4Subject: [PATCH] setup.py: switch from distutils to setuptools
5
6In Python 3.10, distutils is deprecated and slated for removal in Python
73.12. It also prevents 'setup.py bdist_wheel' from building a wheel.
8
9Upstream-Status: Submitted
10[https://github.com/systemd/python-systemd/pull/103]
11
12Signed-off-by: Tim Orling <tim.orling@konsulko.com>
13---
14 setup.py | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/setup.py b/setup.py
18index 099819b..fe9c03a 100644
19--- a/setup.py
20+++ b/setup.py
21@@ -1,5 +1,5 @@
22 import sys, os
23-from distutils.core import setup, Extension
24+from setuptools import setup, Extension
25 from subprocess import Popen, PIPE, check_output
26
27 def call(*cmd):
28--
292.30.2
30