summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb21
1 files changed, 19 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb b/meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb
index 7e2ffdb05b..22dffe6462 100644
--- a/meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-async-timeout_3.0.1.bb
@@ -1,2 +1,19 @@
1inherit setuptools3 1SUMMARY = "asyncio-compatible timeout context manager"
2require python-async-timeout.inc 2DESCRIPTION = "\
3The context manager is useful in cases when you want to apply \
4timeout logic around block of code or in cases when asyncio.wait_for() \
5is not suitable. Also it's much faster than asyncio.wait_for() because \
6timeout doesn't create a new task."
7HOMEPAGE = "https://github.com/aio-libs/async-timeout"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
10
11SRC_URI[md5sum] = "305c4fa529f2485c403d0dbe14390175"
12SRC_URI[sha256sum] = "0c3c816a028d47f659d6ff5c745cb2acf1f966da1fe5c19c77a70282b25f4c5f"
13
14PYPI_PACKAGE = "async-timeout"
15inherit pypi setuptools3
16
17RDEPENDS_${PN} = "\
18 ${PYTHON_PN}-asyncio \
19"