diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python/0001-setup.py-Use-setuptools-instead-of-distutils.patch | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python/0001-setup.py-Use-setuptools-instead-of-distutils.patch b/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python/0001-setup.py-Use-setuptools-instead-of-distutils.patch new file mode 100644 index 0000000000..9bc8b36f36 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python/0001-setup.py-Use-setuptools-instead-of-distutils.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 36f8106535150b970c75e8b8456ebc5a7d1dbdb3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 2 Mar 2022 11:11:01 -0800 | ||
4 | Subject: [PATCH] setup.py: Use setuptools instead of distutils | ||
5 | |||
6 | distutils is deprecated and will be gone in 3.12+ | ||
7 | |||
8 | Upstream-Status: Submitted [https://github.com/aws/aws-iot-device-sdk-python/pull/305] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | setup.py | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/setup.py b/setup.py | ||
15 | index 3846bae..d0c2b8d 100644 | ||
16 | --- a/setup.py | ||
17 | +++ b/setup.py | ||
18 | @@ -3,7 +3,7 @@ sys.path.insert(0, 'AWSIoTPythonSDK') | ||
19 | import AWSIoTPythonSDK | ||
20 | currentVersion = AWSIoTPythonSDK.__version__ | ||
21 | |||
22 | -from distutils.core import setup | ||
23 | +from setuptools import setup | ||
24 | setup( | ||
25 | name = 'AWSIoTPythonSDK', | ||
26 | packages=['AWSIoTPythonSDK', 'AWSIoTPythonSDK.core', | ||
27 | -- | ||
28 | 2.35.1 | ||
29 | |||