summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-click_7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-click_7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-click_7.0.bb26
1 files changed, 25 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-click_7.0.bb b/meta-python/recipes-devtools/python/python3-click_7.0.bb
index 1920644042..cfa3e0fe4f 100644
--- a/meta-python/recipes-devtools/python/python3-click_7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-click_7.0.bb
@@ -1,2 +1,26 @@
1SUMMARY = "A simple wrapper around optparse for powerful command line utilities."
2DESCRIPTION = "\
3Click is a Python package for creating beautiful command line interfaces \
4in a composable way with as little code as necessary. It's the "Command \
5Line Interface Creation Kit". It's highly configurable but comes with \
6sensible defaults out of the box."
7HOMEPAGE = "http://click.pocoo.org/"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=c13ed890b210a882c1778216694c98c7"
10
11SRC_URI[md5sum] = "7f53d50f7b7373ebc7963f9ff697450a"
12SRC_URI[sha256sum] = "5b94b49521f6456670fdb30cd82a4eca9412788a93fa6dd6df72c94d5a8ff2d7"
13
14PYPI_PACKAGE = "Click"
1inherit pypi setuptools3 15inherit pypi setuptools3
2require python-click.inc 16
17UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
18
19CLEANBROKEN = "1"
20
21RDEPENDS_${PN} += "\
22 ${PYTHON_PN}-io \
23 ${PYTHON_PN}-threading \
24 "
25
26BBCLASSEXTEND = "native nativesdk"