diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-click_8.0.4.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-click_8.0.4.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-click_8.0.4.bb b/meta-python/recipes-devtools/python/python3-click_8.0.4.bb new file mode 100644 index 0000000000..76f7a8e652 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-click_8.0.4.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | SUMMARY = "A simple wrapper around optparse for powerful command line utilities." | ||
2 | DESCRIPTION = "\ | ||
3 | Click is a Python package for creating beautiful command line interfaces \ | ||
4 | in a composable way with as little code as necessary. It's the "Command \ | ||
5 | Line Interface Creation Kit". It's highly configurable but comes with \ | ||
6 | sensible defaults out of the box." | ||
7 | HOMEPAGE = "http://click.pocoo.org/" | ||
8 | LICENSE = "BSD-3-Clause" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8" | ||
10 | |||
11 | SRC_URI[sha256sum] = "8458d7b1287c5fb128c90e23381cf99dcde74beaf6c7ff6384ce84d6fe090adb" | ||
12 | |||
13 | inherit pypi setuptools3 ptest | ||
14 | |||
15 | SRC_URI += " \ | ||
16 | file://run-ptest \ | ||
17 | " | ||
18 | |||
19 | RDEPENDS:${PN}-ptest += " \ | ||
20 | ${PYTHON_PN}-pytest \ | ||
21 | ${PYTHON_PN}-terminal \ | ||
22 | ${PYTHON_PN}-unixadmin \ | ||
23 | " | ||
24 | |||
25 | do_install_ptest() { | ||
26 | install -d ${D}${PTEST_PATH}/tests | ||
27 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
28 | cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/ | ||
29 | cp -rf ${S}/docs ${D}${PTEST_PATH}/ | ||
30 | } | ||
31 | |||
32 | UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/" | ||
33 | |||
34 | CLEANBROKEN = "1" | ||
35 | |||
36 | RDEPENDS:${PN} += "\ | ||
37 | ${PYTHON_PN}-io \ | ||
38 | ${PYTHON_PN}-threading \ | ||
39 | " | ||
40 | |||
41 | BBCLASSEXTEND = "native nativesdk" | ||