diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cryptography')
6 files changed, 72 insertions, 73 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/0001-Cargo.toml-specify-pem-version.patch b/meta-python/recipes-devtools/python/python3-cryptography/0001-Cargo.toml-specify-pem-version.patch new file mode 100644 index 0000000000..d7ab757bb5 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-cryptography/0001-Cargo.toml-specify-pem-version.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From ec8d3f3c61280c8140b34ed1479baef5e706f064 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <tim.orling@konsulko.com> | ||
3 | Date: Fri, 14 Jan 2022 22:02:25 -0800 | ||
4 | Subject: [PATCH] Cargo.toml: specify pem version | ||
5 | |||
6 | pem = "1.0" is not resolving, specify the current | ||
7 | pem = { version: "1.0.2"} | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Tim Orling <tim.orling@konsulko.com> | ||
12 | --- | ||
13 | src/rust/Cargo.toml | 2 +- | ||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/src/rust/Cargo.toml b/src/rust/Cargo.toml | ||
17 | index 617167d0..174eaa80 100644 | ||
18 | --- a/src/rust/Cargo.toml | ||
19 | +++ b/src/rust/Cargo.toml | ||
20 | @@ -9,7 +9,7 @@ publish = false | ||
21 | lazy_static = "1" | ||
22 | pyo3 = { version = "0.15.1" } | ||
23 | asn1 = { version = "0.8.7", default-features = false, features = ["derive"] } | ||
24 | -pem = "1.0" | ||
25 | +pem = { version = "1.0.2" } | ||
26 | chrono = { version = "0.4", default-features = false, features = ["alloc", "clock"] } | ||
27 | ouroboros = "0.13" | ||
28 | |||
29 | -- | ||
30 | 2.30.2 | ||
31 | |||
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/0002-Cargo.toml-edition-2018-2021.patch b/meta-python/recipes-devtools/python/python3-cryptography/0002-Cargo.toml-edition-2018-2021.patch new file mode 100644 index 0000000000..366e3a4d39 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-cryptography/0002-Cargo.toml-edition-2018-2021.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 4b73298b214a5b69ea6edf3c2e21dd82b2b29708 Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <tim.orling@konsulko.com> | ||
3 | Date: Fri, 14 Jan 2022 22:34:59 -0800 | ||
4 | Subject: [PATCH 2/2] Cargo.toml: edition 2018 -> 2021 | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Tim Orling <tim.orling@konsulko.com> | ||
9 | --- | ||
10 | src/rust/Cargo.toml | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/src/rust/Cargo.toml b/src/rust/Cargo.toml | ||
14 | index 174eaa80..7ad053d9 100644 | ||
15 | --- a/src/rust/Cargo.toml | ||
16 | +++ b/src/rust/Cargo.toml | ||
17 | @@ -2,7 +2,7 @@ | ||
18 | name = "cryptography-rust" | ||
19 | version = "0.1.0" | ||
20 | authors = ["The cryptography developers <cryptography-dev@python.org>"] | ||
21 | -edition = "2018" | ||
22 | +edition = "2021" | ||
23 | publish = false | ||
24 | |||
25 | [dependencies] | ||
26 | -- | ||
27 | 2.30.2 | ||
28 | |||
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/check-memfree.py b/meta-python/recipes-devtools/python/python3-cryptography/check-memfree.py new file mode 100755 index 0000000000..c111a9074c --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-cryptography/check-memfree.py | |||
@@ -0,0 +1,10 @@ | |||
1 | #!/usr/bin/env python3 | ||
2 | # https://stackoverflow.com/questions/22102999/get-total-physical-memory-in-python/28161352 | ||
3 | import sys | ||
4 | meminfo = dict((i.split()[0].rstrip(':'),int(i.split()[1])) for i in open('/proc/meminfo').readlines()) | ||
5 | mem_free = meminfo['MemTotal']/1024./1024. | ||
6 | if mem_free < 2.: | ||
7 | raise RuntimeError("Insufficient free memory({:.3f}): requires > 2 GB".format(mem_free)) | ||
8 | sys.exit(1) | ||
9 | else: | ||
10 | print("Free memory: {:.3f} GB".format(mem_free)) | ||
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch b/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch deleted file mode 100644 index 9f07c73803..0000000000 --- a/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | --- a/tests/hypothesis/__init__.py | ||
2 | +++ b/tests/hypothesis/__init__.py | ||
3 | @@ -3,3 +3,7 @@ | ||
4 | # for complete details. | ||
5 | |||
6 | from __future__ import absolute_import, division, print_function | ||
7 | + | ||
8 | +import pytest | ||
9 | +hypothesis = pytest.importorskip("hypothesis") | ||
10 | + | ||
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/openssl3.patch b/meta-python/recipes-devtools/python/python3-cryptography/openssl3.patch deleted file mode 100644 index 25baa42cc9..0000000000 --- a/meta-python/recipes-devtools/python/python3-cryptography/openssl3.patch +++ /dev/null | |||
@@ -1,62 +0,0 @@ | |||
1 | Encourage our old python3-cryptography to at least start to work with OpenSSL 3. | ||
2 | |||
3 | - Backport one patch to err.py to remove a symbol which has been removed in | ||
4 | OpenSSL 3, and isn't used in python3-cryptography. | ||
5 | (50ec692749b7e2e62685b443f5e629627b03987e) | ||
6 | |||
7 | - Backport the detection of OpenSSL 3 and don't link to FIPS_mode/FIPS_mode_set | ||
8 | (parts of f08a7de651f9e6475c8c0a67d2a61ed8b669ddf6) | ||
9 | |||
10 | This is *not* a complete backport of the 3.0 support, but is enough that packages | ||
11 | such as imgtool can import python3-cryptography and operate until the upgrade is | ||
12 | ready. | ||
13 | |||
14 | Upstream-Status: Inappropriate | ||
15 | Signed-off-by: Ross Burton <ross.burton@arm.com> | ||
16 | |||
17 | diff --git a/src/_cffi_src/openssl/cryptography.py b/src/_cffi_src/openssl/cryptography.py | ||
18 | index f24bee5a..920a86de 100644 | ||
19 | --- a/src/_cffi_src/openssl/cryptography.py | ||
20 | +++ b/src/_cffi_src/openssl/cryptography.py | ||
21 | @@ -35,6 +35,8 @@ INCLUDES = """ | ||
22 | |||
23 | #define CRYPTOGRAPHY_OPENSSL_110F_OR_GREATER \ | ||
24 | (OPENSSL_VERSION_NUMBER >= 0x1010006f && !CRYPTOGRAPHY_IS_LIBRESSL) | ||
25 | +#define CRYPTOGRAPHY_OPENSSL_300_OR_GREATER \ | ||
26 | + (OPENSSL_VERSION_NUMBER >= 0x30000000 && !CRYPTOGRAPHY_IS_LIBRESSL) | ||
27 | |||
28 | #define CRYPTOGRAPHY_OPENSSL_LESS_THAN_110J \ | ||
29 | (OPENSSL_VERSION_NUMBER < 0x101000af || CRYPTOGRAPHY_IS_LIBRESSL) | ||
30 | @@ -54,6 +56,7 @@ INCLUDES = """ | ||
31 | |||
32 | TYPES = """ | ||
33 | static const int CRYPTOGRAPHY_OPENSSL_110F_OR_GREATER; | ||
34 | +static const int CRYPTOGRAPHY_OPENSSL_300_OR_GREATER; | ||
35 | |||
36 | static const int CRYPTOGRAPHY_OPENSSL_LESS_THAN_111; | ||
37 | static const int CRYPTOGRAPHY_OPENSSL_LESS_THAN_111B; | ||
38 | diff --git a/src/_cffi_src/openssl/err.py b/src/_cffi_src/openssl/err.py | ||
39 | index 0dd74146..42bab4d9 100644 | ||
40 | --- a/src/_cffi_src/openssl/err.py | ||
41 | +++ b/src/_cffi_src/openssl/err.py | ||
42 | @@ -40,7 +40,6 @@ void ERR_clear_error(void); | ||
43 | void ERR_put_error(int, int, int, const char *, int); | ||
44 | |||
45 | int ERR_GET_LIB(unsigned long); | ||
46 | -int ERR_GET_FUNC(unsigned long); | ||
47 | int ERR_GET_REASON(unsigned long); | ||
48 | |||
49 | """ | ||
50 | diff --git a/src/_cffi_src/openssl/fips.py b/src/_cffi_src/openssl/fips.py | ||
51 | index c92bca49..38bfa231 100644 | ||
52 | --- a/src/_cffi_src/openssl/fips.py | ||
53 | +++ b/src/_cffi_src/openssl/fips.py | ||
54 | @@ -18,7 +18,7 @@ int FIPS_mode(void); | ||
55 | """ | ||
56 | |||
57 | CUSTOMIZATIONS = """ | ||
58 | -#if CRYPTOGRAPHY_IS_LIBRESSL | ||
59 | +#if CRYPTOGRAPHY_IS_LIBRESSL || CRYPTOGRAPHY_OPENSSL_300_OR_GREATER | ||
60 | static const long Cryptography_HAS_FIPS = 0; | ||
61 | int (*FIPS_mode_set)(int) = NULL; | ||
62 | int (*FIPS_mode)(void) = NULL; | ||
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/run-ptest b/meta-python/recipes-devtools/python/python3-cryptography/run-ptest index 0ba239c2a4..1e97dda63e 100644 --- a/meta-python/recipes-devtools/python/python3-cryptography/run-ptest +++ b/meta-python/recipes-devtools/python/python3-cryptography/run-ptest | |||
@@ -1,2 +1,4 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | py.test | 2 | if ./check-memfree.py; then |
3 | pytest -vvvv tests/ | ||
4 | fi | ||