summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-flask_3.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-flask_3.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-flask_3.0.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask_3.0.0.bb b/meta-python/recipes-devtools/python/python3-flask_3.0.0.bb
new file mode 100644
index 0000000000..e0afd3718f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask_3.0.0.bb
@@ -0,0 +1,25 @@
1SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions"
2DESCRIPTION = "\
3Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \
4intentions. And before you ask: It’s BSD licensed!"
5HOMEPAGE = "https://github.com/mitsuhiko/flask/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
8
9SRC_URI[sha256sum] = "cfadcdb638b609361d29ec22360d6070a77d7463dcb3ab08d2c2f2f168845f58"
10
11UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/Flask"
12UPSTREAM_CHECK_REGEX = "/Flask/(?P<pver>(\d+[\.\-_]*)+)"
13
14inherit pypi python_setuptools_build_meta
15
16CLEANBROKEN = "1"
17
18RDEPENDS:${PN} = " \
19 ${PYTHON_PN}-blinker \
20 ${PYTHON_PN}-click \
21 ${PYTHON_PN}-itsdangerous \
22 ${PYTHON_PN}-jinja2 \
23 ${PYTHON_PN}-profile \
24 ${PYTHON_PN}-werkzeug \
25"