summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-google-api-core_2.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-google-api-core_2.10.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-api-core_2.10.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-api-core_2.10.1.bb b/meta-python/recipes-devtools/python/python3-google-api-core_2.10.1.bb
new file mode 100644
index 0000000000..c7ded90984
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-api-core_2.10.1.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Google API client core library"
2HOMEPAGE = "https://github.com/googleapis/python-api-core"
3AUTHOR = "Google LLC"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7inherit pypi setuptools3
8
9SRC_URI[sha256sum] = "e16c15a11789bc5a3457afb2818a3540a03f341e6e710d7f9bbf6cde2ef4a7c8"
10
11RDEPENDS:${PN} += "\
12 ${PYTHON_PN}-asyncio \
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-logging \
15 ${PYTHON_PN}-math \
16"
17
18RDEPENDS:${PN} += "\
19 ${PYTHON_PN}-googleapis-common-protos \
20 ${PYTHON_PN}-google-auth \
21 ${PYTHON_PN}-grpcio \
22 ${PYTHON_PN}-protobuf \
23 ${PYTHON_PN}-pytz \
24 ${PYTHON_PN}-requests \
25 ${PYTHON_PN}-six \
26"