summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-google-api-core_2.12.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-google-api-core_2.12.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-google-api-core_2.12.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-google-api-core_2.12.0.bb b/meta-python/recipes-devtools/python/python3-google-api-core_2.12.0.bb
new file mode 100644
index 0000000000..28c6a7989c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-api-core_2.12.0.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Google API client core library"
2HOMEPAGE = "https://github.com/googleapis/python-api-core"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6inherit pypi setuptools3
7
8SRC_URI[sha256sum] = "c22e01b1e3c4dcd90998494879612c38d0a3411d1f7b679eb89e2abe3ce1f553"
9
10RDEPENDS:${PN} += "\
11 ${PYTHON_PN}-asyncio \
12 ${PYTHON_PN}-datetime \
13 ${PYTHON_PN}-logging \
14 ${PYTHON_PN}-math \
15"
16
17RDEPENDS:${PN} += "\
18 ${PYTHON_PN}-googleapis-common-protos \
19 ${PYTHON_PN}-google-auth \
20 ${PYTHON_PN}-grpcio \
21 ${PYTHON_PN}-protobuf \
22 ${PYTHON_PN}-pytz \
23 ${PYTHON_PN}-requests \
24 ${PYTHON_PN}-six \
25"