diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | 13 |
1 files changed, 4 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch index aef67b5748..4713da174f 100644 --- a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch +++ b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | |||
@@ -26,11 +26,9 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
26 | setup.py | 9 ++++++--- | 26 | setup.py | 9 ++++++--- |
27 | 1 file changed, 6 insertions(+), 3 deletions(-) | 27 | 1 file changed, 6 insertions(+), 3 deletions(-) |
28 | 28 | ||
29 | diff --git a/setup.py b/setup.py | ||
30 | index a316038..70aa174 100644 | ||
31 | --- a/setup.py | 29 | --- a/setup.py |
32 | +++ b/setup.py | 30 | +++ b/setup.py |
33 | @@ -76,8 +76,11 @@ def check_linker_need_libatomic(): | 31 | @@ -87,8 +87,11 @@ def check_linker_need_libatomic(): |
34 | """Test if linker on system needs libatomic.""" | 32 | """Test if linker on system needs libatomic.""" |
35 | code_test = (b'#include <atomic>\n' + | 33 | code_test = (b'#include <atomic>\n' + |
36 | b'int main() { return std::atomic<int64_t>{}; }') | 34 | b'int main() { return std::atomic<int64_t>{}; }') |
@@ -44,15 +42,12 @@ index a316038..70aa174 100644 | |||
44 | stdin=PIPE, | 42 | stdin=PIPE, |
45 | stdout=PIPE, | 43 | stdout=PIPE, |
46 | stderr=PIPE) | 44 | stderr=PIPE) |
47 | @@ -87,7 +90,7 @@ def check_linker_need_libatomic(): | 45 | @@ -98,7 +101,7 @@ def check_linker_need_libatomic(): |
48 | # Double-check to see if -latomic actually can solve the problem. | 46 | # Double-check to see if -latomic actually can solve the problem. |
49 | # https://github.com/grpc/grpc/issues/22491 | 47 | # https://github.com/grpc/grpc/issues/22491 |
50 | cpp_test = subprocess.Popen( | 48 | cpp_test = subprocess.Popen( |
51 | - [cxx, '-x', 'c++', '-std=c++11', '-latomic', '-'], | 49 | - [cxx, '-x', 'c++', '-std=c++11', '-', '-latomic'], |
52 | + [cxx, cxx_args, '-x', 'c++', '-std=c++11', '-latomic', '-'], | 50 | + [cxx, cxx_args, '-x', 'c++', '-std=c++11', '-', '-latomic'], |
53 | stdin=PIPE, | 51 | stdin=PIPE, |
54 | stdout=PIPE, | 52 | stdout=PIPE, |
55 | stderr=PIPE) | 53 | stderr=PIPE) |
56 | -- | ||
57 | 2.30.1 | ||
58 | |||