diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio/0001-python-enable-unbundled-cross-compilation.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio/0001-python-enable-unbundled-cross-compilation.patch | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/0001-python-enable-unbundled-cross-compilation.patch b/meta-python/recipes-devtools/python/python3-grpcio/0001-python-enable-unbundled-cross-compilation.patch new file mode 100644 index 0000000000..782b348815 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-grpcio/0001-python-enable-unbundled-cross-compilation.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From ff01ac8908a7267503ffbb85efd24755da0502d8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Peter Marko <peter.marko@siemens.com> | ||
3 | Date: Wed, 5 Feb 2025 21:06:50 +0100 | ||
4 | Subject: [PATCH] python: enable unbundled cross compilation | ||
5 | |||
6 | System headers are on a sysroot path provided by the toolchain | ||
7 | options. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Peter Marko <peter.marko@siemens.com> | ||
11 | --- | ||
12 | setup.py | 10 +++++----- | ||
13 | 1 file changed, 5 insertions(+), 5 deletions(-) | ||
14 | |||
15 | diff --git a/setup.py b/setup.py | ||
16 | index 3b6edbe..d3a0d04 100644 | ||
17 | --- a/setup.py | ||
18 | +++ b/setup.py | ||
19 | @@ -317,25 +317,25 @@ if BUILD_WITH_SYSTEM_OPENSSL: | ||
20 | lambda x: "third_party/boringssl" not in x, CORE_C_FILES | ||
21 | ) | ||
22 | CORE_C_FILES = filter(lambda x: "src/boringssl" not in x, CORE_C_FILES) | ||
23 | - SSL_INCLUDE = (os.path.join("/usr", "include", "openssl"),) | ||
24 | + SSL_INCLUDE = () | ||
25 | |||
26 | if BUILD_WITH_SYSTEM_ZLIB: | ||
27 | CORE_C_FILES = filter(lambda x: "third_party/zlib" not in x, CORE_C_FILES) | ||
28 | - ZLIB_INCLUDE = (os.path.join("/usr", "include"),) | ||
29 | + ZLIB_INCLUDE = () | ||
30 | |||
31 | if BUILD_WITH_SYSTEM_CARES: | ||
32 | CORE_C_FILES = filter(lambda x: "third_party/cares" not in x, CORE_C_FILES) | ||
33 | - CARES_INCLUDE = (os.path.join("/usr", "include"),) | ||
34 | + CARES_INCLUDE = () | ||
35 | |||
36 | if BUILD_WITH_SYSTEM_RE2: | ||
37 | CORE_C_FILES = filter(lambda x: "third_party/re2" not in x, CORE_C_FILES) | ||
38 | - RE2_INCLUDE = (os.path.join("/usr", "include", "re2"),) | ||
39 | + RE2_INCLUDE = () | ||
40 | |||
41 | if BUILD_WITH_SYSTEM_ABSL: | ||
42 | CORE_C_FILES = filter( | ||
43 | lambda x: "third_party/abseil-cpp" not in x, CORE_C_FILES | ||
44 | ) | ||
45 | - ABSL_INCLUDE = (os.path.join("/usr", "include"),) | ||
46 | + ABSL_INCLUDE = () | ||
47 | |||
48 | EXTENSION_INCLUDE_DIRECTORIES = ( | ||
49 | (PYTHON_STEM,) | ||