diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch index 131daace06..f39a82a33d 100644 --- a/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch +++ b/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From b02be74a2eff8abc612ef84f30e0fbce6a7f65f5 Mon Sep 17 00:00:00 2001 | 1 | 1From b02be74a2eff8abc612ef84f30e0fbce6a7f65f5 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Fri, 4 Aug 2017 09:04:07 -0700 | 3 | Date: Fri, 4 Aug 2017 09:04:07 -0700 |
4 | Subject: [PATCH] setup.py: Do not mix C and C++ compiler options | 4 | Subject: [PATCH] setup.py: Do not mix C and C++ compiler options |
@@ -24,7 +24,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
24 | 24 | ||
25 | def check_linker_need_libatomic(): | 25 | def check_linker_need_libatomic(): |
26 | """Test if linker on system needs libatomic.""" | 26 | """Test if linker on system needs libatomic.""" |
27 | + compiler, cc_args = os.environ.get('CC').split(' ', 1) or 'cc' | 27 | + compiler, cc_args = os.environ.get('CC').split(' ', 1) or 'gcc' |
28 | code_test = (b'#include <atomic>\n' + | 28 | code_test = (b'#include <atomic>\n' + |
29 | b'int main() { return std::atomic<int64_t>{}; }') | 29 | b'int main() { return std::atomic<int64_t>{}; }') |
30 | - cc_test = subprocess.Popen(['cc', '-x', 'c++', '-std=c++11', '-'], | 30 | - cc_test = subprocess.Popen(['cc', '-x', 'c++', '-std=c++11', '-'], |
@@ -57,7 +57,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
57 | """ | 57 | """ |
58 | # TODO(lidiz) Remove the generated a.out for success tests. | 58 | # TODO(lidiz) Remove the generated a.out for success tests. |
59 | - cc_test = subprocess.Popen(['cc', '-x', 'c', '-std=c++11', '-'], | 59 | - cc_test = subprocess.Popen(['cc', '-x', 'c', '-std=c++11', '-'], |
60 | + compiler, cc_args = os.environ.get('CC').split(' ', 1) or 'cc' | 60 | + compiler, cc_args = os.environ.get('CC').split(' ', 1) or 'gcc' |
61 | + cc_test = subprocess.Popen([compiler, cc_args, '-x', 'c', '-std=c++11', '-'], | 61 | + cc_test = subprocess.Popen([compiler, cc_args, '-x', 'c', '-std=c++11', '-'], |
62 | stdin=subprocess.PIPE, | 62 | stdin=subprocess.PIPE, |
63 | stdout=subprocess.PIPE, | 63 | stdout=subprocess.PIPE, |