summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-grpcio/boring_ssl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio/boring_ssl.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio/boring_ssl.patch50
1 files changed, 32 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/boring_ssl.patch b/meta-python/recipes-devtools/python/python3-grpcio/boring_ssl.patch
index 65db4a6ed4..d12e35a993 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio/boring_ssl.patch
+++ b/meta-python/recipes-devtools/python/python3-grpcio/boring_ssl.patch
@@ -1,36 +1,50 @@
1From f71b32eb8a5c173fc5733847437b9485d75bb2e5 Mon Sep 17 00:00:00 2001
2From: Leon Anavi <leon.anavi@konsulko.com>
3Date: Fri, 9 Apr 2021 14:06:36 +0300
4Subject: [PATCH] setup.py: Fix determining target platform
5
1Do not poke at the build machine to determine target platform or architecture 6Do not poke at the build machine to determine target platform or architecture
2pass it from environment instead for cross compiling to work 7pass it from environment instead for cross compiling to work
3 8
4Upstream-Status: Inappropriate [OE-Specific] 9Upstream-Status: Inappropriate [OE-Specific]
5Signed-off-by: Khem Raj <raj.khem@gmail.com> 10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
12---
13 setup.py | 11 +++++++----
14 1 file changed, 7 insertions(+), 4 deletions(-)
15
16diff --git a/setup.py b/setup.py
17index c93d419f32..71a944a9d0 100644
6--- a/setup.py 18--- a/setup.py
7+++ b/setup.py 19+++ b/setup.py
8@@ -109,6 +109,8 @@ CLASSIFIERS = [ 20@@ -116,6 +116,9 @@ def _env_bool_value(env_name, default):
9 BUILD_WITH_BORING_SSL_ASM = os.environ.get('GRPC_BUILD_WITH_BORING_SSL_ASM', 21 BUILD_WITH_BORING_SSL_ASM = _env_bool_value('GRPC_BUILD_WITH_BORING_SSL_ASM',
10 True) 22 'True')
11 23
12+BORING_SSL_PLATFORM = os.environ.get('GRPC_BORING_SSL_PLATFORM', 24+BORING_SSL_PLATFORM = os.environ.get('GRPC_BORING_SSL_PLATFORM',
13+ True) 25+ 'True')
14 # Environment variable to determine whether or not the Cython extension should 26+
15 # *use* Cython or use the generated C files. Note that this requires the C files 27 # Export this environment variable to override the platform variant that will
16 # to have been generated by building first *with* Cython support. Even if this 28 # be chosen for boringssl assembly optimizations. This option is useful when
17@@ -306,15 +308,15 @@ asm_key = '' 29 # crosscompiling and the host platform as obtained by distutils.utils.get_platform()
18 if BUILD_WITH_BORING_SSL_ASM and not BUILD_WITH_SYSTEM_OPENSSL: 30@@ -336,13 +339,13 @@ if BUILD_WITH_BORING_SSL_ASM and not BUILD_WITH_SYSTEM_OPENSSL:
19 LINUX_X86_64 = 'linux-x86_64' 31 LINUX_X86_64 = 'linux-x86_64'
20 LINUX_ARM = 'linux-arm' 32 LINUX_ARM = 'linux-arm'
21- if LINUX_X86_64 == util.get_platform(): 33 LINUX_AARCH64 = 'linux-aarch64'
34- if LINUX_X86_64 == boringssl_asm_platform:
22+ if LINUX_X86_64 == BORING_SSL_PLATFORM: 35+ if LINUX_X86_64 == BORING_SSL_PLATFORM:
23 asm_key = 'crypto_linux_x86_64' 36 asm_key = 'crypto_linux_x86_64'
24- elif LINUX_ARM == util.get_platform(): 37- elif LINUX_ARM == boringssl_asm_platform:
25+ elif LINUX_ARM == BORING_SSL_PLATFORM: 38+ elif LINUX_ARM == BORING_SSL_PLATFORM:
26 asm_key = 'crypto_linux_arm' 39 asm_key = 'crypto_linux_arm'
27- elif "mac" in util.get_platform() and "x86_64" in util.get_platform(): 40- elif LINUX_AARCH64 == boringssl_asm_platform:
28+ elif "mac" in BORING_SSL_PLATFORM and "x86_64" in BORING_SSL_PLATFORM: 41+ elif LINUX_AARCH64 == BORING_SSL_PLATFORM:
42 asm_key = 'crypto_linux_aarch64'
43- elif "mac" in boringssl_asm_platform and "x86_64" in boringssl_asm_platform:
44+ elif "mac" in boringssl_asm_platform and "x86_64" in BORING_SSL_PLATFORM:
29 asm_key = 'crypto_mac_x86_64' 45 asm_key = 'crypto_mac_x86_64'
30 else: 46 else:
31 print("ASM Builds for BoringSSL currently not supported on:", 47 print("ASM Builds for BoringSSL currently not supported on:",
32- util.get_platform()) 48--
33+ BORING_SSL_PLATFORM) 492.17.1
34 if asm_key: 50
35 asm_files = grpc_core_dependencies.ASM_SOURCE_FILES[asm_key]
36 else: