summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch
new file mode 100644
index 0000000000..4881b023c8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch
@@ -0,0 +1,28 @@
1From e6c0d487fb5e6063305b8b3187896fbfe5720ed2 Mon Sep 17 00:00:00 2001
2From: Leon Anavi <leon.anavi@konsulko.com>
3Date: Mon, 22 Feb 2021 18:42:43 +0200
4Subject: [PATCH] setup.py: Fix numpy version
5
6Fix numpy version to ensure bitbake will find the pip package.
7
8Upstream-Status: Inappropriate [oe specific]
9
10Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
11
12---
13 setup.py | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/setup.py b/setup.py
17index 7dbe583..6602c97 100755
18--- a/setup.py
19+++ b/setup.py
20@@ -49,7 +49,7 @@ SETUP_REQUIRES = [
21 f"Cython >=0.29; python_version<'3.8'",
22 f"Cython >=0.29.14; python_version>='3.8'",
23 ] + [
24- f"numpy =={np_min}; python_version{py_condition}"
25+ f"numpy >={np_min}; python_version{py_condition}"
26 for np_min, py_condition in NUMPY_MIN_VERSIONS
27 ]
28