diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-kivy')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch b/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch new file mode 100644 index 0000000000..e50c7e7e24 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | diff --git a/setup.py b/setup.py | ||
2 | index 9a507c6c4..3f5b70866 100644 | ||
3 | --- a/setup.py | ||
4 | +++ b/setup.py | ||
5 | @@ -680,7 +680,18 @@ def determine_gl_flags(): | ||
6 | c_options['use_x11'] = True | ||
7 | c_options['use_egl'] = True | ||
8 | else: | ||
9 | - flags['libraries'] = ['GL'] | ||
10 | + if cross_sysroot: | ||
11 | + flags['include_dirs'] = [cross_sysroot + '/usr/include'] | ||
12 | + flags['library_dirs'] = [cross_sysroot + '/usr/lib'] | ||
13 | + | ||
14 | + if c_options['use_opengl_es2']: | ||
15 | + print("using GLESv2 libraries") | ||
16 | + flags['libraries'] = ['GLESv2'] | ||
17 | + else: | ||
18 | + flags['libraries'] = ['GL'] | ||
19 | + | ||
20 | + | ||
21 | + print("cross_sysroot: " + str(cross_sysroot)) | ||
22 | return flags, base_flags | ||
23 | |||
24 | |||