summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch28
1 files changed, 14 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
index 899cac624a..aea8f62ea7 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
+++ b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
@@ -4,19 +4,17 @@ Upstream-Status: Inappropriate [disable feature]
4 4
5Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> 5Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
6 6
7Update patch to fit on 3.7.2.
8
9Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
10
11diff --git a/setup.py b/setup.py
12index 0bea13fa6f..f39d8fc871 100644
7--- a/setup.py 13--- a/setup.py
8+++ b/setup.py 14+++ b/setup.py
9@@ -303,7 +303,6 @@ setup( # Finally, pass this all along t 15@@ -327,13 +327,7 @@ setup( # Finally, pass this all along to setuptools to do the heavy lifting.
10 setup_requires=[
11 "certifi>=2020.06.20",
12 "numpy>=1.19",
13- "setuptools_scm>=7",
14 ],
15 install_requires=[
16 "contourpy>=1.0.1",
17@@ -315,13 +314,7 @@ setup( # Finally, pass this all along t
18 "pillow>=6.2.0", 16 "pillow>=6.2.0",
19 "pyparsing>=2.2.1", 17 "pyparsing>=2.3.1,<3.1",
20 "python-dateutil>=2.7", 18 "python-dateutil>=2.7",
21- ] + ( 19- ] + (
22- # Installing from a git checkout that is not producing a wheel. 20- # Installing from a git checkout that is not producing a wheel.
@@ -26,12 +24,14 @@ Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
26- ) else [] 24- ) else []
27- ), 25- ),
28+ ], 26+ ],
29 use_scm_version={ 27 extras_require={
30 "version_scheme": "release-branch-semver", 28 ':python_version<"3.10"': [
31 "local_scheme": "node-and-date", 29 "importlib-resources>=3.2.0",
30diff --git a/setupext.py b/setupext.py
31index a898d642d6..474172ff8f 100644
32--- a/setupext.py 32--- a/setupext.py
33+++ b/setupext.py 33+++ b/setupext.py
34@@ -65,40 +65,7 @@ def get_from_cache_or_download(url, sha) 34@@ -66,40 +66,7 @@ def get_from_cache_or_download(url, sha):
35 BytesIO 35 BytesIO
36 The file loaded into memory. 36 The file loaded into memory.
37 """ 37 """