summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-multidict/0001-Allow-calling-make-clean-without-sphinx-build.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-multidict/0001-Allow-calling-make-clean-without-sphinx-build.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-multidict/0001-Allow-calling-make-clean-without-sphinx-build.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-multidict/0001-Allow-calling-make-clean-without-sphinx-build.patch b/meta-python/recipes-devtools/python/python3-multidict/0001-Allow-calling-make-clean-without-sphinx-build.patch
new file mode 100644
index 0000000000..d1d7ef5756
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-multidict/0001-Allow-calling-make-clean-without-sphinx-build.patch
@@ -0,0 +1,34 @@
1From 39e13b4e3f7a1d1dd748e80cee241d511865d4e8 Mon Sep 17 00:00:00 2001
2From: Pascal Bach <pascal.bach@nextrem.ch>
3Date: Mon, 16 Jan 2017 21:29:12 +0100
4Subject: [PATCH] Allow calling make clean without sphinx-build
5
6Currently make clean fails without sphinx-build installed
7However sphinx-build is not really necessary to do a clean.
8This trick makes the docs/Makefile use the false binary instead of
9sphinx-build for the check when a clean is done.
10
11Upstream-Status: Submitted https://github.com/aio-libs/multidict/pull/41
12
13---
14 Makefile | 4 ++--
15 1 file changed, 2 insertions(+), 2 deletions(-)
16
17diff --git a/Makefile b/Makefile
18index 8f525f3..6d601e5 100644
19--- a/Makefile
20+++ b/Makefile
21@@ -51,8 +51,8 @@ clean:
22 rm -rf coverage
23 rm -rf build
24 rm -rf cover
25- make -C docs clean
26- python setup.py clean
27+ make -C docs clean SPHINXBUILD=false
28+ python3 setup.py clean
29 rm -f multidict/_multidict.html
30 rm -f multidict/_multidict.c
31 rm -f multidict/_multidict.*.so
32--
332.7.4
34