summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-Downgrade-numpy-version-needs-to-1.x.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-Downgrade-numpy-version-needs-to-1.x.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-Downgrade-numpy-version-needs-to-1.x.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-Downgrade-numpy-version-needs-to-1.x.patch b/meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-Downgrade-numpy-version-needs-to-1.x.patch
new file mode 100644
index 0000000000..b0ef8ce00c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pandas/0001-pyproject.toml-Downgrade-numpy-version-needs-to-1.x.patch
@@ -0,0 +1,27 @@
1From d81d95274d84ac51fc02e0fa91affc7f3cbefccb Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 24 Aug 2024 10:21:43 -0700
4Subject: [PATCH] pyproject.toml: Downgrade numpy version needs to 1.x
5
6Drop it when numpy is upgraded to 2.x or newer in core
7
8Upstream-Status: Inappropriate [OE workaround]
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 pyproject.toml | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/pyproject.toml b/pyproject.toml
16index 5158d60..d3daa78 100644
17--- a/pyproject.toml
18+++ b/pyproject.toml
19@@ -8,7 +8,7 @@ requires = [
20 "Cython>=3.0.5", # Note: sync with setup.py, environment.yml and asv.conf.json
21 # Force numpy higher than 2.0rc1, so that built wheels are compatible
22 # with both numpy 1 and 2
23- "numpy>=2.0.0rc1",
24+ "numpy>=1.24.0",
25 "versioneer[toml]"
26 ]
27