diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyaudio')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyaudio/0001-Remove-absolute-paths-into-build-machine-system-dirs.patch | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyaudio/0001-Remove-absolute-paths-into-build-machine-system-dirs.patch b/meta-python/recipes-devtools/python/python3-pyaudio/0001-Remove-absolute-paths-into-build-machine-system-dirs.patch new file mode 100644 index 0000000000..a71902a362 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pyaudio/0001-Remove-absolute-paths-into-build-machine-system-dirs.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From d94518b558c1812aecb87d8ef19d75c2df1b98a5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 26 Jul 2023 19:54:19 -0700 | ||
4 | Subject: [PATCH] Remove absolute paths into build machine system dirs | ||
5 | |||
6 | This ensures that it does not add /usr/include and /usr/local/include/ | ||
7 | into cflags | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | setup.py | 2 -- | ||
13 | 1 file changed, 2 deletions(-) | ||
14 | |||
15 | --- a/setup.py | ||
16 | +++ b/setup.py | ||
17 | @@ -111,11 +111,6 @@ def setup_extension(): | ||
18 | # the standard portaudio cmake settings. For details, see: | ||
19 | # https://devblogs.microsoft.com/cppblog/vcpkg-updates-static-linking-is-now-available/ | ||
20 | extra_compile_args += ["/MT"] | ||
21 | - else: | ||
22 | - # GNU/Linux and other posix-like OSes will dynamically link to | ||
23 | - # portaudio, installed by the package manager. | ||
24 | - include_dirs += ['/usr/local/include', '/usr/include'] | ||
25 | - external_libraries_path += ['/usr/local/lib', '/usr/lib'] | ||
26 | |||
27 | return Extension( | ||
28 | 'pyaudio._portaudio', | ||