summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pydantic-core_2.14.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pydantic-core_2.14.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pydantic-core_2.14.5.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pydantic-core_2.14.5.bb b/meta-python/recipes-devtools/python/python3-pydantic-core_2.14.5.bb
new file mode 100644
index 0000000000..8221de80b6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pydantic-core_2.14.5.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Provides the core functionality for pydantic validation and serialization."
2DESCRIPTION = "This package provides the core functionality for \
3pydantic validation and serialization.\
4\
5Pydantic-core is currently around 17x faster than pydantic V1."
6HOMEPAGE = "https://github.com/pydantic/pydantic-core"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c"
10
11SRC_URI[sha256sum] = "6d30226dfc816dd0fdf120cae611dd2215117e4f9b124af8c60ab9093b6e8e71"
12
13DEPENDS = "python3-maturin-native python3-typing-extensions"
14
15require ${BPN}-crates.inc
16
17inherit pypi cargo-update-recipe-crates python_maturin
18
19S = "${WORKDIR}/pydantic_core-${PV}"
20
21PYPI_ARCHIVE_NAME = "pydantic_core-${PV}.${PYPI_PACKAGE_EXT}"
22
23RDEPENDS:${PN} += "python3-typing-extensions"
24
25INSANE_SKIP:${PN} = "already-stripped"