summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pymongo_3.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pymongo_3.11.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pymongo_3.11.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_3.11.0.bb b/meta-python/recipes-devtools/python/python3-pymongo_3.11.0.bb
new file mode 100644
index 0000000000..635de22d20
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pymongo_3.11.0.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>"
2DESCRIPTION = "\
3The PyMongo distribution contains tools for interacting with MongoDB \
4database from Python. The bson package is an implementation of the BSON \
5format for Python. The pymongo package is a native Python driver for \
6MongoDB. The gridfs package is a gridfs implementation on top of pymongo."
7HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
10
11SRC_URI[md5sum] = "5d166c8f9500c83314deadebb95b6fd5"
12SRC_URI[sha256sum] = "076a7f2f7c251635cf6116ac8e45eefac77758ee5a77ab7bd2f63999e957613b"
13
14inherit pypi setuptools3
15
16PACKAGES =+ "${PYTHON_PN}-bson"
17
18FILES_${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*"
19
20RDEPENDS_${PYTHON_PN}-bson += " \
21 ${PYTHON_PN}-datetime \
22 ${PYTHON_PN}-json \
23 ${PYTHON_PN}-netclient \
24 ${PYTHON_PN}-numbers \
25 ${PYTHON_PN}-threading \
26"
27
28RDEPENDS_${PN} += " \
29 ${PYTHON_PN}-bson \
30 ${PYTHON_PN}-pprint \
31"