diff options
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pynetlinux/0001-setup.py-switch-to-setuptools.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pynetlinux/0001-setup.py-switch-to-setuptools.patch | 32 |
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pynetlinux/0001-setup.py-switch-to-setuptools.patch b/meta-python/recipes-devtools/python/python3-pynetlinux/0001-setup.py-switch-to-setuptools.patch new file mode 100644 index 0000000000..35bc4a6bd1 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pynetlinux/0001-setup.py-switch-to-setuptools.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From a36abadfb2d135260bef7703a1d0b56e6aa7eeff Mon Sep 17 00:00:00 2001 | ||
2 | From: Tim Orling <tim.orling@konsulko.com> | ||
3 | Date: Mon, 28 Feb 2022 08:21:33 -0800 | ||
4 | Subject: [PATCH] setup.py: switch to setuptools | ||
5 | |||
6 | In Python 3.10, 'distutils' has been deprecated and is slated for | ||
7 | removal in Python 3.12. | ||
8 | |||
9 | Switch from 'distutils.core' to 'setuptools'. This also allows for the | ||
10 | 'wheel' binary archive format to be built with 'setup.py bdist_wheel'. | ||
11 | |||
12 | Upstream-Status: Submitted | ||
13 | [https://github.com/rlisagor/pynetlinux/pull/12] | ||
14 | |||
15 | Signed-off-by: Tim Orling <tim.orling@konsulko.com> | ||
16 | --- | ||
17 | setup.py | 2 +- | ||
18 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
19 | |||
20 | diff --git a/setup.py b/setup.py | ||
21 | index 670e064..45f1053 100755 | ||
22 | --- a/setup.py | ||
23 | +++ b/setup.py | ||
24 | @@ -1,4 +1,4 @@ | ||
25 | -from distutils.core import setup | ||
26 | +from setuptools import setup | ||
27 | |||
28 | setup( | ||
29 | name = "pynetlinux", | ||
30 | -- | ||
31 | 2.30.2 | ||
32 | |||