summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytest_5.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytest_5.4.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytest_5.4.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest_5.4.2.bb b/meta-python/recipes-devtools/python/python3-pytest_5.4.2.bb
new file mode 100644
index 0000000000..9258c21caf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytest_5.4.2.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Simple powerful testing with python"
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b"
5
6SRC_URI[sha256sum] = "eb2b5e935f6a019317e455b6da83dd8650ac9ffd2ee73a7b657a30873d67a698"
7
8SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch "
9
10inherit update-alternatives pypi setuptools3
11
12RDEPENDS_${PN}_class-target += " \
13 ${PYTHON_PN}-attrs \
14 ${PYTHON_PN}-debugger \
15 ${PYTHON_PN}-doctest \
16 ${PYTHON_PN}-json \
17 ${PYTHON_PN}-pluggy \
18 ${PYTHON_PN}-py \
19 ${PYTHON_PN}-setuptools \
20 ${PYTHON_PN}-six \
21 ${PYTHON_PN}-atomicwrites \
22 ${PYTHON_PN}-importlib-metadata \
23 ${PYTHON_PN}-pathlib2 \
24 ${PYTHON_PN}-wcwidth \
25 ${PYTHON_PN}-more-itertools \
26 ${PYTHON_PN}-packaging \
27"
28
29ALTERNATIVE_${PN} += "py.test pytest"
30
31NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
32ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
33
34ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
35ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
36
37BBCLASSEXTEND = "native nativesdk"